summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-12 05:24:32 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-12 05:24:32 +0000
commit802441f4277ee5a224a451f4bcdaf714ebb500ed (patch)
tree9396c3d8ce059f6339ede92e382b7bc3a5e8314b
parentVersion bump. (diff)
downloadgentoo-2-802441f4277ee5a224a451f4bcdaf714ebb500ed.tar.gz
gentoo-2-802441f4277ee5a224a451f4bcdaf714ebb500ed.tar.bz2
gentoo-2-802441f4277ee5a224a451f4bcdaf714ebb500ed.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/capistrano/ChangeLog7
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index bad79fd9c439..c367c4e202ad 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.95 2013/07/08 18:44:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.96 2013/07/12 05:24:32 graaff Exp $
+
+*capistrano-2.15.5 (12 Jul 2013)
+
+ 12 Jul 2013; Hans de Graaff <graaff@gentoo.org> +capistrano-2.15.5.ebuild:
+ Version bump.
08 Jul 2013; Hans de Graaff <graaff@gentoo.org> -capistrano-2.13.4.ebuild,
-capistrano-2.13.5.ebuild, -capistrano-2.14.1.ebuild:
diff --git a/dev-ruby/capistrano/capistrano-2.15.5.ebuild b/dev-ruby/capistrano/capistrano-2.15.5.ebuild
new file mode 100644
index 000000000000..c067ad5eb8ad
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.15.5.ebuild,v 1.1 2013/07/12 05:24:32 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.12.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}