summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-06 20:42:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-06 20:42:57 +0000
commit810d1e0051d5c8a00d7eb74f8cf3295936613d80 (patch)
treeae1f2a83ab9e0560f8617d1881340f5484f828ce
parentRemove old. (diff)
downloadgentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.tar.gz
gentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.tar.bz2
gentoo-2-810d1e0051d5c8a00d7eb74f8cf3295936613d80.zip
Add upstream patch to support +4GiB file sizes. Bug #142945 by Vadim. Add
epunt_cxx for bug #185600 by Laurence Withers. Maintainer-needed commit. (Portage version: 2.1.3.12)
-rw-r--r--net-libs/librsync/ChangeLog9
-rw-r--r--net-libs/librsync/files/digest-librsync-0.9.7-r13
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-huge-files.patch31
-rw-r--r--net-libs/librsync/librsync-0.9.7-r1.ebuild36
4 files changed, 78 insertions, 1 deletions
diff --git a/net-libs/librsync/ChangeLog b/net-libs/librsync/ChangeLog
index 0f2abd468e63..b44024935f8d 100644
--- a/net-libs/librsync/ChangeLog
+++ b/net-libs/librsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/librsync
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/ChangeLog,v 1.25 2007/03/19 02:44:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/ChangeLog,v 1.26 2007/10/06 20:42:57 dirtyepic Exp $
+
+*librsync-0.9.7-r1 (06 Oct 2007)
+
+ 06 Oct 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/librsync-0.9.7-huge-files.patch, +librsync-0.9.7-r1.ebuild:
+ Add upstream patch to support +4GiB file sizes. Bug #142945 by Vadim. Add
+ epunt_cxx for bug #185600 by Laurence Withers. Maintainer-needed commit.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/net-libs/librsync/files/digest-librsync-0.9.7-r1 b/net-libs/librsync/files/digest-librsync-0.9.7-r1
new file mode 100644
index 000000000000..99163abf7806
--- /dev/null
+++ b/net-libs/librsync/files/digest-librsync-0.9.7-r1
@@ -0,0 +1,3 @@
+MD5 24cdb6b78f45e0e83766903fd4f6bc84 librsync-0.9.7.tar.gz 453802
+RMD160 39ca29334d0efabc0ee9e4d44abbe73a7d2fe831 librsync-0.9.7.tar.gz 453802
+SHA256 6633e4605662763a03bb6388529cbdfd3b11a9ec55b8845351c1bd9a92bc41d6 librsync-0.9.7.tar.gz 453802
diff --git a/net-libs/librsync/files/librsync-0.9.7-huge-files.patch b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
new file mode 100644
index 000000000000..fef08941a44f
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-huge-files.patch
@@ -0,0 +1,31 @@
+diff -urN librsync-0.9.7/mdfour.h librsync-0.9.7dev/mdfour.h
+--- librsync-0.9.7/mdfour.h 2004-02-07 18:17:57.000000000 -0500
++++ librsync-0.9.7dev/mdfour.h 2006-03-06 03:21:46.000000000 -0500
+@@ -24,7 +24,7 @@
+ #include "types.h"
+
+ struct rs_mdfour {
+- int A, B, C, D;
++ unsigned int A, B, C, D;
+ #if HAVE_UINT64
+ uint64_t totalN;
+ #else
+diff -urN librsync-0.9.7/patch.c librsync-0.9.7dev/patch.c
+--- librsync-0.9.7/patch.c 2004-09-17 17:35:50.000000000 -0400
++++ librsync-0.9.7dev/patch.c 2006-03-06 03:21:06.000000000 -0500
+@@ -214,12 +214,12 @@
+ void *buf, *ptr;
+ rs_buffers_t *buffs = job->stream;
+
+- len = job->basis_len;
+-
+ /* copy only as much as will fit in the output buffer, so that we
+ * don't have to block or store the input. */
+- if (len > buffs->avail_out)
++ if (job->basis_len > buffs->avail_out)
+ len = buffs->avail_out;
++ else
++ len = job->basis_len;
+
+ if (!len)
+ return RS_BLOCKED;
diff --git a/net-libs/librsync/librsync-0.9.7-r1.ebuild b/net-libs/librsync/librsync-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..112de79858da
--- /dev/null
+++ b/net-libs/librsync/librsync-0.9.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/librsync-0.9.7-r1.ebuild,v 1.1 2007/10/06 20:42:57 dirtyepic Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Flexible remote checksum-based differencing"
+HOMEPAGE="http://librsync.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Bug #142945
+ epatch "${FILESDIR}"/${P}-huge-files.patch
+
+ # Bug #185600
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS AUTHORS THANKS README TODO
+}