summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-15 12:07:13 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-15 12:07:13 +0000
commit8307f039cef5f45ca708db62a7e9a9654df41948 (patch)
treedb37fc4ed7aef47d713762837a42d61f1f7b1646
parentbump, needed for celery-3.0.21, corrections & updates to deps (diff)
downloadgentoo-2-8307f039cef5f45ca708db62a7e9a9654df41948.tar.gz
gentoo-2-8307f039cef5f45ca708db62a7e9a9654df41948.tar.bz2
gentoo-2-8307f039cef5f45ca708db62a7e9a9654df41948.zip
Split 1.3 slot into 1.38 and 1.40 slots as they don't both work with reverse dependencies. The mess in this folder will be dealt with after the reverse dependencies have been fixed.
(Portage version: 2.2.0/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 6D34E57D)
-rw-r--r--dev-java/bcprov/ChangeLog11
-rw-r--r--dev-java/bcprov/bcprov-1.38-r3.ebuild57
-rw-r--r--dev-java/bcprov/bcprov-1.40-r1.ebuild59
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-java/bcprov/ChangeLog b/dev-java/bcprov/ChangeLog
index d38938536b7d..c0666a826990 100644
--- a/dev-java/bcprov/ChangeLog
+++ b/dev-java/bcprov/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-java/bcprov
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.52 2013/08/15 10:25:21 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/ChangeLog,v 1.53 2013/08/15 12:07:13 tomwij Exp $
+
+*bcprov-1.38-r3 (15 Aug 2013)
+*bcprov-1.40-r1 (15 Aug 2013)
+
+ 15 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +bcprov-1.38-r3.ebuild,
+ +bcprov-1.40-r1.ebuild:
+ Split 1.3 slot into 1.38 and 1.40 slots as they don't both work with reverse
+ dependencies. The mess in this folder will be dealt with after the reverse
+ dependencies have been fixed.
*bcprov-1.45-r1 (15 Aug 2013)
*bcprov-1.48-r1 (15 Aug 2013)
diff --git a/dev-java/bcprov/bcprov-1.38-r3.ebuild b/dev-java/bcprov/bcprov-1.38-r3.ebuild
new file mode 100644
index 000000000000..fc439a7eb83e
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.38-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/bcprov-1.38-r3.ebuild,v 1.1 2013/08/15 12:07:13 tomwij Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk14-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.38"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# The src_unpack find needs a new find
+# https://bugs.gentoo.org/show_bug.cgi?id=182276
+DEPEND=">=virtual/jdk-1.4
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+IUSE="userland_GNU"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./src.zip
+
+ # so that we don't need junit
+ echo "Removing testcases' sources:"
+ find . -path '*test/*.java' -print -delete \
+ || die "Failed to delete testcases."
+ find . -name '*Test*.java' -print -delete \
+ || die "Failed to delete testcases."
+}
+
+src_compile() {
+ mkdir "${S}/classes"
+
+ find . -name "*.java" > "${T}/src.list"
+ ejavac -encoding ISO-8859-1 -d "${S}/classes" "@${T}/src.list"
+
+ cd "${S}/classes"
+ jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar "${S}/${PN}.jar"
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}
diff --git a/dev-java/bcprov/bcprov-1.40-r1.ebuild b/dev-java/bcprov/bcprov-1.40-r1.ebuild
new file mode 100644
index 000000000000..8e3e7086c2b8
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.40-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/bcprov-1.40-r1.ebuild,v 1.1 2013/08/15 12:07:13 tomwij Exp $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="1.40"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# The src_unpack find needs a new find
+# https://bugs.gentoo.org/show_bug.cgi?id=182276
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+IUSE="userland_GNU"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+
+ # so that we don't need junit
+ echo "Removing testcases' sources:"
+ find . -path '*test/*.java' -print -delete \
+ || die "Failed to delete testcases."
+ find . -name '*Test*.java' -print -delete \
+ || die "Failed to delete testcases."
+}
+
+src_compile() {
+ mkdir "${S}/classes"
+
+ find . -name "*.java" > "${T}/src.list"
+ ejavac -encoding ISO-8859-1 -d "${S}/classes" "@${T}/src.list"
+
+ cd "${S}/classes"
+ jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar "${S}/${PN}.jar"
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}