summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 19:53:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 19:53:21 +0000
commit87ae1b87f457cdd7c2b5195da7a65b4c149501cb (patch)
tree29d5f5ebdac72f79e335cf144d24c69836e81326
parentVersion bump (bug #254926), clean out old versions. (diff)
downloadgentoo-2-87ae1b87f457cdd7c2b5195da7a65b4c149501cb.tar.gz
gentoo-2-87ae1b87f457cdd7c2b5195da7a65b4c149501cb.tar.bz2
gentoo-2-87ae1b87f457cdd7c2b5195da7a65b4c149501cb.zip
EAPI=2; add use-based dep
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
-rw-r--r--games-arcade/stepmania/ChangeLog7
-rw-r--r--games-arcade/stepmania/stepmania-3.9.ebuild21
2 files changed, 11 insertions, 17 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index 400276c53aad..92a334e09b78 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/stepmania
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.26 2008/11/24 16:48:22 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.27 2009/01/19 19:53:21 mr_bones_ Exp $
+
+ 19 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> stepmania-3.9.ebuild:
+ EAPI=2; add use-based dep
24 Nov 2008; <ssuominen@gentoo.org> stepmania-3.9.ebuild:
Move patchset tarball out of my old dev space to gentoo mirrors.
diff --git a/games-arcade/stepmania/stepmania-3.9.ebuild b/games-arcade/stepmania/stepmania-3.9.ebuild
index 08fe3056d543..45868e40182a 100644
--- a/games-arcade/stepmania/stepmania-3.9.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.17 2008/11/24 16:48:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.18 2009/01/19 19:53:21 mr_bones_ Exp $
+EAPI=2
inherit autotools eutils games
MY_PV=${PV/_/-}
@@ -22,7 +23,7 @@ RESTRICT="test"
RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
mad? ( media-libs/libmad )
>=dev-lang/lua-5
- media-libs/libsdl
+ media-libs/libsdl[opengl]
jpeg? ( media-libs/jpeg )
media-libs/libpng
ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
@@ -34,16 +35,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/StepMania-${MY_PV}-src
-pkg_setup() {
- games_pkg_setup
- built_with_use media-libs/libsdl opengl \
- || die "You need to compile media-libs/libsdl with USE=opengl."
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed "s:/usr/share/games/${PN}:${GAMES_DATADIR}/${PN}:" \
"${FILESDIR}"/${P}-gentoo.patch > "${T}"/gentoo.patch
@@ -57,7 +49,7 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
econf --disable-dependency-tracking \
$(use_with debug) \
$(use_with jpeg) \
@@ -65,7 +57,6 @@ src_compile() {
$(use_with mad mp3) \
$(use_enable gtk gtk2) \
$(use_enable force-oss)
- emake || die "emake failed."
}
src_install() {