summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-22 04:21:03 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-22 04:21:03 +0000
commit8a5e12687434d49780d5e5a9e36c272b0b154c56 (patch)
treecb67dbe485cc779d4346c0304a25aa2ee3c644df
parentSome more fixes regarding VBoxNetNAT (diff)
downloadgentoo-2-8a5e12687434d49780d5e5a9e36c272b0b154c56.tar.gz
gentoo-2-8a5e12687434d49780d5e5a9e36c272b0b154c56.tar.bz2
gentoo-2-8a5e12687434d49780d5e5a9e36c272b0b154c56.zip
initial commit for dogpile.core for dogpile.cache for keystone 2013.2.*
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--dev-python/dogpile-core/ChangeLog9
-rw-r--r--dev-python/dogpile-core/Manifest3
-rw-r--r--dev-python/dogpile-core/dogpile-core-0.4.1.ebuild26
-rw-r--r--dev-python/dogpile-core/metadata.xml15
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/dogpile-core/ChangeLog b/dev-python/dogpile-core/ChangeLog
new file mode 100644
index 000000000000..b518aeae9d73
--- /dev/null
+++ b/dev-python/dogpile-core/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/dogpile-core
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dogpile-core/ChangeLog,v 1.1 2013/10/22 04:21:03 prometheanfire Exp $
+
+*dogpile-core-0.4.1 (22 Oct 2013)
+
+ 22 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +dogpile-core-0.4.1.ebuild, +metadata.xml:
+ initial commit for dogpile.core for dogpile.cache for keystone 2013.2.*
diff --git a/dev-python/dogpile-core/Manifest b/dev-python/dogpile-core/Manifest
new file mode 100644
index 000000000000..25d4b2d8f002
--- /dev/null
+++ b/dev-python/dogpile-core/Manifest
@@ -0,0 +1,3 @@
+DIST dogpile.core-0.4.1.tar.gz 99534 SHA256 af2555702811d56846778d39451cf822b04b3f13347080c121a4977fefdfcbff SHA512 f4c37297788677afe6ab17ba5aa928f9770b0edbd1a675cd4ad512ef0c15cf1e2d765d9b7a9fe3638f0a646e0ad51d54c9b4ded33611022744226bfde1aa9896 WHIRLPOOL 09677b564eee99202e66bba97b9e8db36a75aa1c3e86616a043db8b6bff318031c2afe72f9c243e19cc106e546aa9cc422820aeee505a7f5627f64c808af1eec
+EBUILD dogpile-core-0.4.1.ebuild 838 SHA256 9ba4dfb229d3875e225c21f369e7c87883bae77b60713930a92f976b4e0fce16 SHA512 be91f45d4a0b1b5c84fe3e27d17147cc31cbc34a66d950c8e22d52f80ae89f72eb76adf48b1410c4b3e4cf3f6f4dfcf5e407bc67b98805393bdd8e14fe46793a WHIRLPOOL 56604947817734b20a33f11f917a7677725687e77ec18da87f2177fc48422508b1e129f5e83ce6f761186e3723aef773123060f9fbda742b8f1ebe234b583a92
+MISC metadata.xml 484 SHA256 ec3f5a416c347b1181a1f8ce0da00f24afc26b50ad327e31a274741d11797583 SHA512 641a406162210d08556f3d03ef4f3bf31d42f9cfb9d510b422fac83474f2eeb7a1717aa82485656c15786e92d9a5535b0aa34b845e943ae8cb47089a3cc1524f WHIRLPOOL e992f959b46cec46e547a790408da8e2cfa7499155f46ed3e33f9d61dd1d2ed3518d7fe93e5e8cff75e4aff1abaf5ae4262737d007591e40f69a038de2faf8f1
diff --git a/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild b/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild
new file mode 100644
index 000000000000..148cda595b32
--- /dev/null
+++ b/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild,v 1.1 2013/10/22 04:21:03 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lock which allows a thread to generate an expensive resource while other threads use the old value"
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.core"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.core/dogpile.core-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.core-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/dogpile-core/metadata.xml b/dev-python/dogpile-core/metadata.xml
new file mode 100644
index 000000000000..0800d9491a13
--- /dev/null
+++ b/dev-python/dogpile-core/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A "dogpile" lock, one which allows a single thread to generate an
+ expensive resource while other threads use the "old" value,
+ until the "new" value is ready.
+ </longdescription>
+</pkgmetadata>
+