summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-14 12:53:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-14 12:53:45 +0000
commit8b015b9be9b01482c1d2024bc38252191e7f4ddf (patch)
tree1f9de81315325572cb7b9932d4c1781904c051d3
parentVersion bump. (diff)
downloadgentoo-2-8b015b9be9b01482c1d2024bc38252191e7f4ddf.tar.gz
gentoo-2-8b015b9be9b01482c1d2024bc38252191e7f4ddf.tar.bz2
gentoo-2-8b015b9be9b01482c1d2024bc38252191e7f4ddf.zip
Version bump to use eselect-lib-bin-symlink library.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--app-admin/eselect-pinentry/ChangeLog10
-rw-r--r--app-admin/eselect-pinentry/eselect-pinentry-0.4.ebuild23
-rw-r--r--app-admin/eselect-pinentry/files/pinentry.eselect-0.413
3 files changed, 44 insertions, 2 deletions
diff --git a/app-admin/eselect-pinentry/ChangeLog b/app-admin/eselect-pinentry/ChangeLog
index c02b5d3be506..57bab4b87290 100644
--- a/app-admin/eselect-pinentry/ChangeLog
+++ b/app-admin/eselect-pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-pinentry
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pinentry/ChangeLog,v 1.14 2012/11/28 07:34:35 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pinentry/ChangeLog,v 1.15 2013/01/14 12:53:45 ssuominen Exp $
+
+*eselect-pinentry-0.4 (14 Jan 2013)
+
+ 14 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +files/pinentry.eselect-0.4, +eselect-pinentry-0.4.ebuild:
+ Version bump to use eselect-lib-bin-symlink library.
28 Nov 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Add to crypto herd.
diff --git a/app-admin/eselect-pinentry/eselect-pinentry-0.4.ebuild b/app-admin/eselect-pinentry/eselect-pinentry-0.4.ebuild
new file mode 100644
index 000000000000..3b333a3140c2
--- /dev/null
+++ b/app-admin/eselect-pinentry/eselect-pinentry-0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-pinentry/eselect-pinentry-0.4.ebuild,v 1.1 2013/01/14 12:53:45 ssuominen Exp $
+
+EAPI=5
+
+DESCRIPTION="Manages the /bin/sh (POSIX shell) symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect-lib-bin-symlink"
+
+S=${FILESDIR}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-admin/eselect-pinentry/files/pinentry.eselect-0.4 b/app-admin/eselect-pinentry/files/pinentry.eselect-0.4
new file mode 100644
index 000000000000..0bcd07d29678
--- /dev/null
+++ b/app-admin/eselect-pinentry/files/pinentry.eselect-0.4
@@ -0,0 +1,13 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: pinentry.eselect-0.4,v 1.1 2013/01/14 12:53:45 ssuominen Exp $
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="ssuominen@gentoo.org"
+VERSION="0.4"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=( pinentry-qt pinentry-gtk-2 pinentry-qt4 pinentry-curses )
+SYMLINK_DESCRIPTION='pinentry implementation'
+
+inherit bin-symlink