summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-04-21 17:59:22 +0000
committerSven Wegener <swegener@gentoo.org>2007-04-21 17:59:22 +0000
commit8b5230066a238357d070f3900ffdd244fca11748 (patch)
tree05281c282715353be3f7ea1c1fcbab337582d83d
parentStable on ppc64; bug #174939 (diff)
downloadgentoo-2-8b5230066a238357d070f3900ffdd244fca11748.tar.gz
gentoo-2-8b5230066a238357d070f3900ffdd244fca11748.tar.bz2
gentoo-2-8b5230066a238357d070f3900ffdd244fca11748.zip
Fix for systems where inotify is not available.
(Portage version: 2.1.2.4)
-rw-r--r--net-dns/avahi/ChangeLog6
-rw-r--r--net-dns/avahi/avahi-0.6.18.ebuild3
-rw-r--r--net-dns/avahi/files/avahi-0.6.18-inotify-ifdef-fix.patch18
3 files changed, 25 insertions, 2 deletions
diff --git a/net-dns/avahi/ChangeLog b/net-dns/avahi/ChangeLog
index ef61add44fa4..7eae7e65ccc1 100644
--- a/net-dns/avahi/ChangeLog
+++ b/net-dns/avahi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/avahi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.96 2007/04/21 16:47:52 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/ChangeLog,v 1.97 2007/04/21 17:59:22 swegener Exp $
+
+ 21 Apr 2007; Sven Wegener <swegener@gentoo.org>
+ +files/avahi-0.6.18-inotify-ifdef-fix.patch, avahi-0.6.18.ebuild:
+ Fix for systems where inotify is not available.
21 Apr 2007; Sven Wegener <swegener@gentoo.org> avahi-0.6.18.ebuild:
Workaround for ServiceTypeDatabase.py bug.
diff --git a/net-dns/avahi/avahi-0.6.18.ebuild b/net-dns/avahi/avahi-0.6.18.ebuild
index 591250c747e1..53ec75633e27 100644
--- a/net-dns/avahi/avahi-0.6.18.ebuild
+++ b/net-dns/avahi/avahi-0.6.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 2000-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.18.ebuild,v 1.3 2007/04/21 16:47:52 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/avahi/avahi-0.6.18.ebuild,v 1.4 2007/04/21 17:59:22 swegener Exp $
inherit eutils mono python qt3 qt4
@@ -93,6 +93,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.6.1-no-ipv6.patch
+ epatch "${FILESDIR}"/${P}-inotify-ifdef-fix.patch
rm -f avahi-python/avahi/ServiceTypeDatabase.py
}
diff --git a/net-dns/avahi/files/avahi-0.6.18-inotify-ifdef-fix.patch b/net-dns/avahi/files/avahi-0.6.18-inotify-ifdef-fix.patch
new file mode 100644
index 000000000000..78654551b519
--- /dev/null
+++ b/net-dns/avahi/files/avahi-0.6.18-inotify-ifdef-fix.patch
@@ -0,0 +1,18 @@
+Index: trunk/avahi-daemon/main.c
+===================================================================
+--- trunk/avahi-daemon/main.c (revision 1450)
++++ trunk/avahi-daemon/main.c (working copy)
+@@ -42,11 +42,13 @@
+ #include <sys/resource.h>
+ #include <sys/socket.h>
+
++#ifdef HAVE_INOTIFY
+ #ifdef HAVE_SYS_INOTIFY_H
+ #include <sys/inotify.h>
+ #else
+ #include "inotify-nosys.h"
+ #endif
++#endif
+
+ #include <libdaemon/dfork.h>
+ #include <libdaemon/dsignal.h>