summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-29 03:54:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-29 03:54:48 +0000
commit8ed3528a34c4250c5e07eb46696ef894cad51e40 (patch)
tree05eb75b54c7dd4f2159c22987736133e41a56d94
parentversion bump (Bug 33995) and java fix (Manifest recommit) (diff)
downloadgentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.tar.gz
gentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.tar.bz2
gentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.zip
change virtual/glibc to virtual/libc
-rw-r--r--app-shells/ash/ash-1.6.ebuild3
-rw-r--r--app-shells/bash-completion/bash-completion-20040526-r2.ebuild12
-rw-r--r--app-shells/bash-completion/bash-completion-20040526.ebuild13
-rw-r--r--app-shells/bash/bash-2.05b-r5.ebuild10
-rw-r--r--app-shells/bash/bash-2.05b-r7.ebuild10
-rw-r--r--app-shells/bash/bash-2.05b-r8.ebuild10
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild4
-rw-r--r--app-shells/bashish/bashish-1.9.21.ebuild5
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r2.ebuild26
-rw-r--r--app-shells/dash/dash-0.4.24.ebuild10
-rw-r--r--app-shells/dash/dash-0.4.26.ebuild10
-rw-r--r--app-shells/esh/esh-0.8-r2.ebuild32
-rw-r--r--app-shells/esh/esh-0.8.5.ebuild31
13 files changed, 86 insertions, 90 deletions
diff --git a/app-shells/ash/ash-1.6.ebuild b/app-shells/ash/ash-1.6.ebuild
index 36840dad0f0d..3b491e821f22 100644
--- a/app-shells/ash/ash-1.6.ebuild
+++ b/app-shells/ash/ash-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.11 2004/06/24 22:22:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.12 2004/06/29 03:50:32 vapier Exp $
inherit eutils
@@ -27,6 +27,7 @@ src_unpack() {
-f ${DISTDIR}/bin.tar.gz src/bin/sh)
epatch ${DISTDIR}/dash-ash-hetio-yacc.diff.bz2
}
+
src_compile() {
# pmake name conflicts, use full path
/usr/bin/pmake CFLAGS:="-Wall -DBSD=1 -D_GNU_SOURCE -DGLOB_BROKEN \
diff --git a/app-shells/bash-completion/bash-completion-20040526-r2.ebuild b/app-shells/bash-completion/bash-completion-20040526-r2.ebuild
index d1e833fe4577..10deeee8a5a8 100644
--- a/app-shells/bash-completion/bash-completion-20040526-r2.ebuild
+++ b/app-shells/bash-completion/bash-completion-20040526-r2.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040526-r2.ebuild,v 1.2 2004/06/24 22:23:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040526-r2.ebuild,v 1.3 2004/06/29 03:51:30 vapier Exp $
GENCOMP_VERS="1.0_beta"
-DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
-
-S=${WORKDIR}/${PN/-/_}
+IUSE=""
DEPEND="app-arch/tar
app-arch/bzip2"
-
RDEPEND=">=app-shells/bash-2.05a"
+S=${WORKDIR}/${PN/-/_}
+
src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash-completion/bash-completion-20040526.ebuild b/app-shells/bash-completion/bash-completion-20040526.ebuild
index 45b89d7ebad6..a660c4216eca 100644
--- a/app-shells/bash-completion/bash-completion-20040526.ebuild
+++ b/app-shells/bash-completion/bash-completion-20040526.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040526.ebuild,v 1.3 2004/06/24 22:23:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040526.ebuild,v 1.4 2004/06/29 03:51:30 vapier Exp $
-S=${WORKDIR}/${PN/-/_}
-DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha mips hppa amd64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64 s390"
+IUSE=""
DEPEND="app-arch/tar
app-arch/bzip2"
-
RDEPEND=">=app-shells/bash-2.05a"
+S=${WORKDIR}/${PN/-/_}
+
src_install() {
insinto /etc
doins bash_completion
diff --git a/app-shells/bash/bash-2.05b-r5.ebuild b/app-shells/bash/bash-2.05b-r5.ebuild
index 7a93cd18d95e..74f481574197 100644
--- a/app-shells/bash/bash-2.05b-r5.ebuild
+++ b/app-shells/bash/bash-2.05b-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r5.ebuild,v 1.12 2004/06/24 22:22:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r5.ebuild,v 1.13 2004/06/29 03:51:06 vapier Exp $
inherit eutils flag-o-matic
@@ -8,14 +8,14 @@ inherit eutils flag-o-matic
PLEVEL="x002 x003 x004"
DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
SRC_URI="mirror://gnu/bash/${P}.tar.gz
mirror://gentoo/${P}-gentoo.diff.bz2
${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 x86 ppc sparc ~alpha mips hppa"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips ~alpha hppa amd64"
IUSE="nls build"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -76,7 +76,7 @@ src_install() {
&& rm -rf ${D}/usr \
|| ( \
doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
dodoc doc/FAQ doc/INTRO
ebegin "creating info symlink"
diff --git a/app-shells/bash/bash-2.05b-r7.ebuild b/app-shells/bash/bash-2.05b-r7.ebuild
index 951fa78c8e8c..ded715677455 100644
--- a/app-shells/bash/bash-2.05b-r7.ebuild
+++ b/app-shells/bash/bash-2.05b-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r7.ebuild,v 1.16 2004/06/24 22:22:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r7.ebuild,v 1.17 2004/06/29 03:51:06 vapier Exp $
inherit eutils flag-o-matic
@@ -8,14 +8,14 @@ inherit eutils flag-o-matic
PLEVEL="x002 x003 x004 x005 x006 x007"
DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
SRC_URI="mirror://gnu/bash/${P}.tar.gz
mirror://gentoo/${P}-gentoo.diff.bz2
${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc alpha hppa mips amd64 ia64 ppc64"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64 ia64 ppc64"
IUSE="nls build"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -79,7 +79,7 @@ src_install() {
&& rm -rf ${D}/usr \
|| ( \
doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
dodoc doc/FAQ doc/INTRO
ebegin "creating info symlink"
diff --git a/app-shells/bash/bash-2.05b-r8.ebuild b/app-shells/bash/bash-2.05b-r8.ebuild
index a7838619bdd2..76abb64e90b9 100644
--- a/app-shells/bash/bash-2.05b-r8.ebuild
+++ b/app-shells/bash/bash-2.05b-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r8.ebuild,v 1.6 2004/06/24 22:22:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r8.ebuild,v 1.7 2004/06/29 03:51:07 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -8,14 +8,14 @@ inherit eutils flag-o-matic gnuconfig
PLEVEL="x002 x003 x004 x005 x006 x007"
DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
SRC_URI="mirror://gnu/bash/${P}.tar.gz
mirror://gentoo/${P}-gentoo.diff.bz2
${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
-HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ppc64"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ppc64"
IUSE="nls build"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -84,7 +84,7 @@ src_install() {
&& rm -rf ${D}/usr \
|| ( \
doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
dodoc doc/FAQ doc/INTRO
ebegin "creating info symlink"
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
index e651c70dfb30..b92e5252d44a 100644
--- a/app-shells/bash/bash-2.05b-r9.ebuild
+++ b/app-shells/bash/bash-2.05b-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.15 2004/06/24 22:22:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.16 2004/06/29 03:51:07 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/bash/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ppc64 sparc mips alpha arm hppa amd64 ia64 s390"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
IUSE="nls build uclibc"
DEPEND=">=sys-libs/ncurses-5.2-r2"
diff --git a/app-shells/bashish/bashish-1.9.21.ebuild b/app-shells/bashish/bashish-1.9.21.ebuild
index 26663372aa8a..1ec75f3611c3 100644
--- a/app-shells/bashish/bashish-1.9.21.ebuild
+++ b/app-shells/bashish/bashish-1.9.21.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bashish/bashish-1.9.21.ebuild,v 1.5 2004/06/24 22:23:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bashish/bashish-1.9.21.ebuild,v 1.6 2004/06/29 03:51:55 vapier Exp $
DESCRIPTION="Text console theme engine"
HOMEPAGE="http://bashish.sourceforge.net/"
SRC_URI="mirror://sourceforge/bashish/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc alpha sparc"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE=""
src_unpack() {
unpack ${A}
diff --git a/app-shells/ccsh/ccsh-0.0.4-r2.ebuild b/app-shells/ccsh/ccsh-0.0.4-r2.ebuild
index 224ef3c01b8d..4defc22e5d77 100644
--- a/app-shells/ccsh/ccsh-0.0.4-r2.ebuild
+++ b/app-shells/ccsh/ccsh-0.0.4-r2.ebuild
@@ -1,32 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r2.ebuild,v 1.15 2004/06/24 22:23:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r2.ebuild,v 1.16 2004/06/29 03:52:15 vapier Exp $
DESCRIPTION="UNIX Shell for people already familiar with the C language"
+HOMEPAGE="http://ccsh.sourceforge.net/"
SRC_URI="http://download.sourceforge.net/ccsh/${P}.tar.gz"
-HOMEPAGE="http://ccsh.sourceforge.net"
-KEYWORDS="x86 ppc sparc"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
-
- make CFLAGS="${CFLAGS}" all
+ make CFLAGS="${CFLAGS}" all || die
}
src_install() {
-
into /
- dobin ccsh
+ dobin ccsh || die
into /usr
newman ccsh.man ccsh.1
- dodoc ChangeLog COPYING README TODO
-
+ dodoc ChangeLog README TODO
}
-
-
-
-
-
diff --git a/app-shells/dash/dash-0.4.24.ebuild b/app-shells/dash/dash-0.4.24.ebuild
index 7b8ee9034f34..bf6e34023690 100644
--- a/app-shells/dash/dash-0.4.24.ebuild
+++ b/app-shells/dash/dash-0.4.24.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.4.24.ebuild,v 1.6 2004/06/24 22:23:59 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.4.24.ebuild,v 1.7 2004/06/29 03:53:13 vapier Exp $
MY_P="${P/-/_}"
-S=${WORKDIR}/${PN}
DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
SRC_URI="http://ftp.debian.org/debian/pool/main/d/dash/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
DEPEND="sys-devel/pmake
sys-apps/sed
dev-util/yacc"
+S=${WORKDIR}/${PN}
+
src_compile() {
# pmake name conflicts, use full path
/usr/bin/pmake CFLAGS:="-Wall -DBSD=1 -DSMALL -D_GNU_SOURCE -DGL \
diff --git a/app-shells/dash/dash-0.4.26.ebuild b/app-shells/dash/dash-0.4.26.ebuild
index 80efe9075b43..28968675acce 100644
--- a/app-shells/dash/dash-0.4.26.ebuild
+++ b/app-shells/dash/dash-0.4.26.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.4.26.ebuild,v 1.2 2004/06/24 22:23:59 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.4.26.ebuild,v 1.3 2004/06/29 03:53:13 vapier Exp $
MY_P="${P/-/_}"
-S=${WORKDIR}/${PN}
DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
SRC_URI="http://ftp.debian.org/debian/pool/main/d/dash/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~x86 ~ppc"
+IUSE=""
DEPEND="sys-devel/pmake
sys-apps/sed
dev-util/yacc"
+S=${WORKDIR}/${PN}
+
src_compile() {
# pmake name conflicts, use full path
/usr/bin/pmake CFLAGS:="-Wall -DBSD=1 -DSMALL -D_GNU_SOURCE -DGL \
diff --git a/app-shells/esh/esh-0.8-r2.ebuild b/app-shells/esh/esh-0.8-r2.ebuild
index 9f446b7a1c97..a0eee00acaa6 100644
--- a/app-shells/esh/esh-0.8-r2.ebuild
+++ b/app-shells/esh/esh-0.8-r2.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r2.ebuild,v 1.15 2004/06/24 22:24:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r2.ebuild,v 1.16 2004/06/29 03:54:48 vapier Exp $
-S=${WORKDIR}/esh
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
-SRC_URI="http://esh.netpedia.net/${P}.tar.gz"
HOMEPAGE="http://esh.netpedia.net/"
-KEYWORDS="x86 sparc"
-SLOT="0"
+SRC_URI="http://esh.netpedia.net/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/readline-4.1"
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
-src_compile() {
+S=${WORKDIR}/${PN}
- cp Makefile Makefile.orig
- sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
- -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+src_compile() {
+ sed -i \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile
make || die
}
src_install() {
-
- dobin esh
- into /usr
+ dobin esh || die
doinfo doc/esh.info
- dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ dodoc CHANGELOG CREDITS GC_README HEADER READLNE-HACKS TODO
docinto html
dodoc doc/*.html
docinto examples
diff --git a/app-shells/esh/esh-0.8.5.ebuild b/app-shells/esh/esh-0.8.5.ebuild
index 5b77bb2489d6..9b20c99a0118 100644
--- a/app-shells/esh/esh-0.8.5.ebuild
+++ b/app-shells/esh/esh-0.8.5.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.12 2004/06/24 22:24:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.13 2004/06/29 03:54:48 vapier Exp $
-S=${WORKDIR}/esh
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
-SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
HOMEPAGE="http://slon.ttk.ru/esh/"
-KEYWORDS="x86 -ppc sparc"
-SLOT="0"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc sparc"
+IUSE=""
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/readline-4.1"
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+S=${WORKDIR}/${PN}
src_compile() {
-
- cp Makefile Makefile.orig
- sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
+ sed -i \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
-e "s:^LIB=:LIB=-lncurses :" \
-e "s:-ltermcap::" \
- Makefile.orig > Makefile
+ Makefile
# For some reason, this tarball has binary files in it for x86.
# Make clean so we can rebuild for our arch and optimization.
make clean
@@ -29,11 +30,9 @@ src_compile() {
}
src_install() {
-
- dobin esh
- into /usr
+ dobin esh || die
doinfo doc/esh.info
- dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ dodoc CHANGELOG CREDITS GC_README HEADER READLNE-HACKS TODO
dohtml doc/*.html
docinto examples
dodoc examples/*