summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-02 06:17:27 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-02 06:17:27 +0000
commit9144336a293247e46526826fcdee90df396f3866 (patch)
tree71bf50936da11cea8a795b49f84d617e4b5e1f68
parentBump (diff)
downloadgentoo-2-9144336a293247e46526826fcdee90df396f3866.tar.gz
gentoo-2-9144336a293247e46526826fcdee90df396f3866.tar.bz2
gentoo-2-9144336a293247e46526826fcdee90df396f3866.zip
sys-kernel/aufs-sources: Bump to latest linux and genpatches
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sys-kernel/aufs-sources/ChangeLog7
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.11.3.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index 9fe0124b7440..21981f822154 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.60 2013/09/30 14:45:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.61 2013/10/02 06:17:27 jlec Exp $
+
+*aufs-sources-3.11.3 (02 Oct 2013)
+
+ 02 Oct 2013; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.11.3.ebuild:
+ Bump to latest linux and genpatches
30 Sep 2013; Justin Lecher <jlec@gentoo.org> aufs-sources-3.4.63.ebuild,
aufs-sources-3.10.13.ebuild, aufs-sources-3.11.2.ebuild:
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.11.3.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.11.3.ebuild
new file mode 100644
index 000000000000..9d2ac963ed21
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.11.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.11.3.ebuild,v 1.1 2013/10/02 06:17:27 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="6"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.11_p20130923
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module proc"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${AUFS_URI}"
+
+UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch"
+
+PDEPEND=">=sys-fs/aufs-util-3.9"
+
+src_unpack() {
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+ use proc && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-proc_map.patch"
+ unpack ${AUFS_TARBALL}
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ if ! use proc; then
+ sed '/config AUFS_PROC_MAP/,/^$/d' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/linux/aufs_type.h include/linux/aufs_type.h || die
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util && \
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}