summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-11 03:46:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-11 03:46:33 +0000
commit917ce5d6be8f5322d2db859c7e44aa8d7dbfb9e1 (patch)
treeaf25cdf35561ca09659a874694c601656492f96f
parentAdd m68k/s390/sh love #536874. (diff)
downloadgentoo-2-917ce5d6be8f5322d2db859c7e44aa8d7dbfb9e1.tar.gz
gentoo-2-917ce5d6be8f5322d2db859c7e44aa8d7dbfb9e1.tar.bz2
gentoo-2-917ce5d6be8f5322d2db859c7e44aa8d7dbfb9e1.zip
Bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--net-libs/nodejs/ChangeLog9
-rw-r--r--net-libs/nodejs/nodejs-0.10.38.ebuild73
-rw-r--r--net-libs/nodejs/nodejs-0.12.2-r2.ebuild111
3 files changed, 192 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index ab51621a370c..6d2c285c3176 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.142 2015/04/11 17:39:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.143 2015/05/11 03:46:33 patrick Exp $
+
+*nodejs-0.10.38 (11 May 2015)
+*nodejs-0.12.2-r2 (11 May 2015)
+
+ 11 May 2015; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.38.ebuild,
+ +nodejs-0.12.2-r2.ebuild:
+ Bump
*nodejs-0.12.2-r1 (11 Apr 2015)
diff --git a/net-libs/nodejs/nodejs-0.10.38.ebuild b/net-libs/nodejs/nodejs-0.10.38.ebuild
new file mode 100644
index 000000000000..0b6d88c4fe71
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.38.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.38.ebuild,v 1.1 2015/05/11 03:46:33 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 pax-utils toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm +snapshot"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ tc-export CC CXX
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+ ! use snapshot && myconf="${myconf} --without-snapshot"
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --shared-openssl --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ local V=1
+ export V
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}
diff --git a/net-libs/nodejs/nodejs-0.12.2-r2.ebuild b/net-libs/nodejs/nodejs-0.12.2-r2.ebuild
new file mode 100644
index 000000000000..5eed90157ceb
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.12.2-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.12.2-r2.ebuild,v 1.1 2015/05/11 03:46:33 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="debug icu +npm +snapshot +ssl"
+
+RDEPEND="icu? ( dev-libs/icu )
+ ${PYTHON_DEPS}
+ ssl? ( dev-libs/openssl:0=[-bindist] )
+ >=net-libs/http-parser-2.3
+ >=dev-libs/libuv-1.4.2"
+DEPEND="${RDEPEND}
+ !!net-libs/iojs"
+
+S="${WORKDIR}/node-v${PV}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1 # Verbose build
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+ sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py
+ BUILDTYPE=Debug
+ fi
+}
+
+src_configure() {
+ local myconf=()
+ local myarch=""
+ use debug && myconf+=( --debug )
+ use icu && myconf+=( --with-intl=system-icu )
+ use npm || myconf+=( --without-npm )
+ use snapshot || myconf+=( --without-snapshot )
+ use ssl || myconf+=( --without-ssl )
+
+ case ${ABI} in
+ x86) myarch="ia32";;
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ *) die "Unrecognized ARCH ${ARCH}";;
+ esac
+
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ --shared-openssl \
+ --shared-libuv \
+ --shared-http-parser \
+ --shared-zlib \
+ --without-dtrace \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${ED}"
+ use npm && dodoc -r "${LIBDIR}"/node_modules/npm/html
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
+ find "${LIBDIR}"/node_modules -type f -name "LICENSE" -delete
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ declare -xl TESTTYPE="${BUILDTYPE}"
+ "${PYTHON}" tools/test.py --mode=${TESTTYPE} -J message simple || die
+}