summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-03-27 19:34:45 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-03-27 19:34:45 +0000
commit937d2e2a62f8b620e19dc9ed6ed7a5288e07c061 (patch)
tree1b8fa4a69c620f27251f3eda6bea676b8af84525
parentFixed permition problem reported in bug #171989. Added pid patch to fix start... (diff)
downloadgentoo-2-937d2e2a62f8b620e19dc9ed6ed7a5288e07c061.tar.gz
gentoo-2-937d2e2a62f8b620e19dc9ed6ed7a5288e07c061.tar.bz2
gentoo-2-937d2e2a62f8b620e19dc9ed6ed7a5288e07c061.zip
Bug 169189, gsl as a use flag
(Portage version: 2.1.2.2)
-rw-r--r--dev-perl/PDL/ChangeLog7
-rw-r--r--dev-perl/PDL/PDL-2.4.3-r1.ebuild82
-rw-r--r--dev-perl/PDL/files/digest-PDL-2.4.3-r13
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index 8a4b14dc42bd..68834cf2523c 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/PDL
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.63 2007/03/26 17:43:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.64 2007/03/27 19:34:45 mcummings Exp $
+
+*PDL-2.4.3-r1 (27 Mar 2007)
+
+ 27 Mar 2007; Michael Cummings <mcummings@gentoo.org> +PDL-2.4.3-r1.ebuild:
+ Bug 169189, gsl as a use flag
26 Mar 2007; Raúl Porcel <armin76@gentoo.org> PDL-2.4.3.ebuild:
Add ~ia64 wrt bug 165651
diff --git a/dev-perl/PDL/PDL-2.4.3-r1.ebuild b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..6fc9598057a5
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.3-r1.ebuild,v 1.1 2007/03/27 19:34:45 mcummings Exp $
+
+inherit perl-module eutils multilib
+
+DESCRIPTION="PDL Perl Module"
+HOMEPAGE="http://search.cpan.org/~csoe/"
+SRC_URI="mirror://cpan/authors/id/C/CS/CSOE/${P}.tar.gz"
+
+LICENSE="Artistic as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~sh ~sparc ~x86"
+IUSE="opengl badval gsl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl-core/Filter
+ virtual/perl-File-Spec
+ dev-perl/Inline
+ dev-perl/Astro-FITS-Header
+ >=dev-perl/ExtUtils-F77-1.13
+ virtual/perl-Text-Balanced
+ opengl? ( virtual/opengl virtual/glu )
+ dev-perl/Term-ReadLine-Perl
+ gsl? ( sci-libs/gsl )
+ >=sys-apps/sed-4"
+
+mydoc="DEPENDENCIES DEVELOPMENT MANIFEST* Release_Notes TODO"
+
+#SRC_TEST="do"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}; epatch ${FILESDIR}/PDL-2.4.2-makemakerfix.patch
+ # This 'fix' breaks compiles for non-opengl users
+ #if ! use opengl ; then
+ # sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ # ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ #fi
+
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" \
+ ${S}/perldl.conf
+ fi
+
+
+ # Unconditional -fPIC for the lib (#55238)
+ sed -i -e "s/mycompiler -c -o/mycompiler -fPIC -c -o/" ${S}/Lib/Slatec/Makefile.PL
+}
+
+src_install() {
+ perl-module_src_install
+ dodir /usr/share/doc/${PF}/html
+ eval `perl '-V:version'`
+ PERLVERSION=${version}
+ eval `perl '-V:archname'`
+ ARCHVERSION=${archname}
+ mv ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/HtmlDocs/PDL \
+ ${D}/usr/share/doc/${PF}/html
+
+ mydir=${D}/usr/share/doc/${PF}/html/PDL
+
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+ cp ${S}/Doc/scantree.pl ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+ cp ${S}/Doc/mkhtmldoc.pl ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+}
+
+pkg_postinst() {
+ perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ elog "perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl"
+ epause 3
+ elog "PDL requires that glx and dri support be enabled in"
+ elog "your X configuration for certain parts of the graphics"
+ elog "engine to work. See your X's documentation for futher"
+ elog "information."
+}
diff --git a/dev-perl/PDL/files/digest-PDL-2.4.3-r1 b/dev-perl/PDL/files/digest-PDL-2.4.3-r1
new file mode 100644
index 000000000000..be86cc885706
--- /dev/null
+++ b/dev-perl/PDL/files/digest-PDL-2.4.3-r1
@@ -0,0 +1,3 @@
+MD5 8fa453a4ac90d5c0382020d5635ad90a PDL-2.4.3.tar.gz 2247010
+RMD160 346a4effabcc363de134a94681175126266fca73 PDL-2.4.3.tar.gz 2247010
+SHA256 c1687e74f8304223ddcec59a0d0cc6322f0db43153bd00a8b9ed9fdf0eb7bcae PDL-2.4.3.tar.gz 2247010