summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-12 19:49:18 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-12 19:49:18 +0000
commit9984e116aee8f84d73ff667f9ecbc3af34f10b9c (patch)
tree62d5badaf14e5f7c4571d173c8b49ed78fc91e04
parentVersion bump (diff)
downloadgentoo-2-9984e116aee8f84d73ff667f9ecbc3af34f10b9c.tar.gz
gentoo-2-9984e116aee8f84d73ff667f9ecbc3af34f10b9c.tar.bz2
gentoo-2-9984e116aee8f84d73ff667f9ecbc3af34f10b9c.zip
Revision bump: EAPI 5, epatch_user support, new upstream patchset, generic cleanups
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--net-misc/pump/ChangeLog10
-rw-r--r--net-misc/pump/pump-0.8.24-r4.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/net-misc/pump/ChangeLog b/net-misc/pump/ChangeLog
index 08526d7f122e..5f4fcb7dad51 100644
--- a/net-misc/pump/ChangeLog
+++ b/net-misc/pump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/pump
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.51 2012/12/16 14:17:50 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.52 2013/01/12 19:49:18 pinkbyte Exp $
+
+*pump-0.8.24-r4 (12 Jan 2013)
+
+ 12 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> +pump-0.8.24-r4.ebuild:
+ Revision bump: EAPI 5, epatch_user support, new upstream patchset, generic
+ cleanups
16 Dec 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due retirement, #95685
diff --git a/net-misc/pump/pump-0.8.24-r4.ebuild b/net-misc/pump/pump-0.8.24-r4.ebuild
new file mode 100644
index 000000000000..16c9c07c6fa9
--- /dev/null
+++ b/net-misc/pump/pump-0.8.24-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24-r4.ebuild,v 1.1 2013/01/12 19:49:18 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+PATCHLEVEL="7"
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/popt-1.5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix Debian patch to fit epatch logic
+ sed -i \
+ -e 's:/debian::g' \
+ -e '/^---/s:pump-0.8.24.orig/::' \
+ -e '/^+++/s:pump-0.8.24/::' \
+ "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff" || die "sed on ${PN}_${PV}-${PATCHLEVEL}.diff failed"
+
+ # Apply Debians pump patchset - they fix things good :)
+ # Debian patchset 7 include gentoo patchset too
+ epatch "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff"
+ EPATCH_FORCE="yes" EPATCH_SOURCE="patches" EPATCH_SUFFIX="patch" epatch
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEB_CFLAGS="-fPIC ${CFLAGS}" pump
+}
+
+src_install() {
+ exeinto /sbin
+ doexe pump
+
+ doman pump.8
+ dodoc changelog CREDITS
+
+ dolib.a libpump.a
+ doheader pump.h
+}