summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-28 14:53:29 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-28 14:53:29 +0000
commit99cf4d7fc9cb67201852af958ba534b8c79a6200 (patch)
treeae904f7ee7288c8841d3dde3ca501dc1ac322ac8
parentRemove outdated version. Fixes bug 510676. (diff)
downloadgentoo-2-99cf4d7fc9cb67201852af958ba534b8c79a6200.tar.gz
gentoo-2-99cf4d7fc9cb67201852af958ba534b8c79a6200.tar.bz2
gentoo-2-99cf4d7fc9cb67201852af958ba534b8c79a6200.zip
patch to fix tests, fixes Bug #510834 by Patrick, re-keyword ~arm, tested on armv7, cubieboard2 wrt Bug #510832 also by Patrick
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/twisted-pair/ChangeLog7
-rw-r--r--dev-python/twisted-pair/files/14.0.0-tests.patch26
-rw-r--r--dev-python/twisted-pair/twisted-pair-14.0.0.ebuild7
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/twisted-pair/ChangeLog b/dev-python/twisted-pair/ChangeLog
index 75b3425d8fa1..a8a966d4e852 100644
--- a/dev-python/twisted-pair/ChangeLog
+++ b/dev-python/twisted-pair/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-pair
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-pair/ChangeLog,v 1.28 2014/05/20 07:10:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-pair/ChangeLog,v 1.29 2014/05/28 14:53:29 idella4 Exp $
+
+ 28 May 2014; Ian Delaney <idella4@gentoo.org> +files/14.0.0-tests.patch,
+ twisted-pair-14.0.0.ebuild:
+ patch to fix tests, fixes Bug #510834 by Patrick, re-keyword ~arm, tested on
+ armv7, cubieboard2 wrt Bug #510832 also by Patrick
*twisted-pair-14.0.0 (20 May 2014)
diff --git a/dev-python/twisted-pair/files/14.0.0-tests.patch b/dev-python/twisted-pair/files/14.0.0-tests.patch
new file mode 100644
index 000000000000..0ec7a032eb71
--- /dev/null
+++ b/dev-python/twisted-pair/files/14.0.0-tests.patch
@@ -0,0 +1,26 @@
+Allows user to access /dev/net/tun
+--- twisted/pair/test/test_tuntap.py.orig 2014-05-27 22:55:56.230232748 -0400
++++ twisted/pair/test/test_tuntap.py 2014-05-27 23:30:02.769956742 -0400
+@@ -10,7 +10,7 @@
+ import os
+ import struct
+ import socket
+-from errno import EPERM, EBADF, EINVAL, EAGAIN, EWOULDBLOCK, ENOENT, ENODEV
++from errno import EPERM, EBADF, EINVAL, EAGAIN, EWOULDBLOCK, ENOENT, ENODEV, EACCES
+ from random import randrange
+ from collections import deque
+ from itertools import cycle
+@@ -582,8 +582,11 @@
+ except OSError as e:
+ # The device file may simply be missing. The device file may also
+ # exist but be unsupported by the kernel.
+- if e.errno in (ENOENT, ENODEV) and filename == b"/dev/net/tun":
+- raise SkipTest("Platform lacks /dev/net/tun")
++ if filename == b"/dev/net/tun":
++ if e.errno in (ENOENT, ENODEV):
++ raise SkipTest("Platform lacks /dev/net/tun")
++ elif e.errno == EACCES:
++ raise SkipTest("Access denied opening /dev/net/tun")
+ raise
+
+
diff --git a/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild b/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild
index a52d9d6c90dc..7032c997c587 100644
--- a/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild
+++ b/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild,v 1.1 2014/05/20 07:10:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-pair/twisted-pair-14.0.0.ebuild,v 1.2 2014/05/28 14:53:29 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -9,9 +9,12 @@ inherit twisted-r1
DESCRIPTION="Twisted low-level networking"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/eunuchs[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+
+# https://twistedmatrix.com/trac/ticket/7433
+PATCHES=( "${FILESDIR}"/${PV}-tests.patch )