summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-10-13 15:16:41 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-10-13 15:16:41 +0000
commit9e2c4fda5c66f946af5e6dca644d4b5fff9192f8 (patch)
tree47d1777f740791fc382a4c1b29b160a978ee2538
parentOnly convert files that are mentioned in the patchs and only do it for _p ebu... (diff)
downloadgentoo-2-9e2c4fda5c66f946af5e6dca644d4b5fff9192f8.tar.gz
gentoo-2-9e2c4fda5c66f946af5e6dca644d4b5fff9192f8.tar.bz2
gentoo-2-9e2c4fda5c66f946af5e6dca644d4b5fff9192f8.zip
Initial commit, use temporary gnustep-make so real gnustep-make can depend on this one day
(Portage version: 2.2_rc94/cvs/Linux x86_64)
-rw-r--r--gnustep-base/libobjc2/ChangeLog11
-rw-r--r--gnustep-base/libobjc2/libobjc2-1.0.ebuild49
-rw-r--r--gnustep-base/libobjc2/metadata.xml27
3 files changed, 87 insertions, 0 deletions
diff --git a/gnustep-base/libobjc2/ChangeLog b/gnustep-base/libobjc2/ChangeLog
new file mode 100644
index 000000000000..014977044cf8
--- /dev/null
+++ b/gnustep-base/libobjc2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for gnustep-base/libobjc2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/ChangeLog,v 1.1 2010/10/13 15:16:41 voyageur Exp $
+
+*libobjc2-1.0 (13 Oct 2010)
+
+ 13 Oct 2010; Bernard Cafarelli <voyageur@gentoo.org> +libobjc2-1.0.ebuild,
+ +metadata.xml:
+ Initial commit, use temporary gnustep-make so real gnustep-make can depend
+ on this one day
+
diff --git a/gnustep-base/libobjc2/libobjc2-1.0.ebuild b/gnustep-base/libobjc2/libobjc2-1.0.ebuild
new file mode 100644
index 000000000000..d10d21671f58
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/libobjc2/libobjc2-1.0.ebuild,v 1.1 2010/10/13 15:16:41 voyageur Exp $
+
+EAPI=3
+inherit multilib
+
+# We need gnustep-make, but gnustep-make can depend on libobjc
+# Use a temporary setup to install in /usr/
+GSMAKE=gnustep-make-2.4.0
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="http://download.gna.org/gnustep/${P}.tar.bz2
+ ftp://ftp.gnustep.org/pub/gnustep/core/${GSMAKE}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+GSMAKE_S=${WORKDIR}/${GSMAKE}
+
+src_prepare() {
+ # Multilib-strict
+ cd "${GSMAKE_S}"
+ sed -e "s/lib/$(get_libdir)/g" \
+ -i FilesystemLayouts/fhs-system || die "multilib path sed failed"
+}
+
+src_configure() {
+ cd "${GSMAKE_S}"
+ econf --with-layout=fhs-system
+}
+
+src_compile() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" || die "compilation failed"
+}
+
+src_install() {
+ emake GNUSTEP_MAKEFILES="${GSMAKE_S}" \
+ GNUSTEP_CONFIG_FILE="${GSMAKE_S}"/GNUstep.conf \
+ GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
+ DESTDIR="${D}" install || die "install has failed"
+}
diff --git a/gnustep-base/libobjc2/metadata.xml b/gnustep-base/libobjc2/metadata.xml
new file mode 100644
index 000000000000..6d5c816014c3
--- /dev/null
+++ b/gnustep-base/libobjc2/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>
+The GNUstep Objective-C runtime is designed as a drop-in replacement for the
+GCC runtime. It supports both a legacy and a modern ABI, allowing code
+compiled with old versions of GCC to be supported without requiring
+recompilation. The modern ABI adds the following features:
+
+- Non-fragile instance variables.
+- Protocol uniquing.
+- Object planes support.
+- Declared property introspection.
+
+Both ABIs support the following feature above and beyond the GCC runtime:
+
+- The modern Objective-C runtime APIs, introduced with OS X 10.5.
+- Blocks (closures).
+- Low memory profile for platforms where memory usage is more important than
+ speed.
+- Synthesised property accessors.
+- Efficient support for @synchronized()
+- Type-dependent dispatch, eliminating stack corruption from mismatched
+ selectors.
+</longdescription>
+</pkgmetadata>