summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-24 01:47:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-24 01:47:08 +0000
commita04c9aadab39e0c25cb2e855b080a19ae15ab58c (patch)
tree60c6238012bb1ea2794b1b3f83e8bfdf06d59101
parentarm KEYWORDS (diff)
downloadgentoo-2-a04c9aadab39e0c25cb2e855b080a19ae15ab58c.tar.gz
gentoo-2-a04c9aadab39e0c25cb2e855b080a19ae15ab58c.tar.bz2
gentoo-2-a04c9aadab39e0c25cb2e855b080a19ae15ab58c.zip
arm lovin
(Portage version: 2.0.51-r15)
-rw-r--r--dev-libs/libxml2/libxml2-2.6.16.ebuild9
-rw-r--r--dev-libs/libxml2/libxml2-2.6.17.ebuild9
-rw-r--r--dev-util/subversion/subversion-1.1.1-r3.ebuild13
-rw-r--r--dev-util/subversion/subversion-1.1.3-r1.ebuild14
-rw-r--r--dev-util/subversion/subversion-1.1.3.ebuild13
5 files changed, 28 insertions, 30 deletions
diff --git a/dev-libs/libxml2/libxml2-2.6.16.ebuild b/dev-libs/libxml2/libxml2-2.6.16.ebuild
index de2d00ec641d..05b0f810444a 100644
--- a/dev-libs/libxml2/libxml2-2.6.16.ebuild
+++ b/dev-libs/libxml2/libxml2-2.6.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.16.ebuild,v 1.6 2005/02/06 23:54:58 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.16.ebuild,v 1.7 2005/02/24 01:47:08 vapier Exp $
inherit libtool gnome.org flag-o-matic gnuconfig
@@ -9,13 +9,14 @@ HOMEPAGE="http://www.xmlsoft.org/"
LICENSE="MIT"
SLOT="2"
-KEYWORDS="x86 ~ppc sparc mips alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="alpha ~amd64 arm hppa ia64 mips ~ppc ~ppc64 s390 sh sparc x86"
IUSE="python readline ipv6"
-DEPEND="sys-libs/zlib
+RDEPEND="sys-libs/zlib
python? ( dev-lang/python )
- hppa? ( >=sys-devel/binutils-2.15.92.0.2 )
readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
src_unpack() {
diff --git a/dev-libs/libxml2/libxml2-2.6.17.ebuild b/dev-libs/libxml2/libxml2-2.6.17.ebuild
index f1d41c2f2e17..9b2b47f74ca1 100644
--- a/dev-libs/libxml2/libxml2-2.6.17.ebuild
+++ b/dev-libs/libxml2/libxml2-2.6.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.17.ebuild,v 1.1 2005/01/25 10:22:06 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.17.ebuild,v 1.2 2005/02/24 01:47:08 vapier Exp $
inherit libtool gnome.org flag-o-matic gnuconfig
@@ -9,13 +9,14 @@ HOMEPAGE="http://www.xmlsoft.org/"
LICENSE="MIT"
SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="python readline ipv6"
-DEPEND="sys-libs/zlib
+RDEPEND="sys-libs/zlib
python? ( dev-lang/python )
- hppa? ( >=sys-devel/binutils-2.15.92.0.2 )
readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
src_unpack() {
diff --git a/dev-util/subversion/subversion-1.1.1-r3.ebuild b/dev-util/subversion/subversion-1.1.1-r3.ebuild
index dd13080f0c8f..5d3b14188ebd 100644
--- a/dev-util/subversion/subversion-1.1.1-r3.ebuild
+++ b/dev-util/subversion/subversion-1.1.1-r3.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.1-r3.ebuild,v 1.13 2005/02/15 14:45:15 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.1-r3.ebuild,v 1.14 2005/02/24 01:42:35 vapier Exp $
inherit elisp-common libtool python eutils bash-completion
DESCRIPTION="A compelling replacement for CVS"
-SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
HOMEPAGE="http://subversion.tigris.org/"
+SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
-SLOT="0"
LICENSE="Apache-1.1"
-KEYWORDS="x86 sparc ~ppc amd64 alpha hppa ppc64 ia64"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ppc64 sparc x86"
IUSE="ssl apache2 berkdb python emacs perl java"
-S=${WORKDIR}/${P/_rc/-rc}
-
# Presently subversion doesn't build with swig-1.3.22, bug 65424
RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
!apache2? ( !>=net-www/apache-2* )
@@ -25,12 +23,13 @@ RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
berkdb? ( =sys-libs/db-4* )
java? ( virtual/jdk )
emacs? ( virtual/emacs )"
-
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.59"
# Does not work because jikes is broken
# jikes? (dev-java/jikes)"
+S=${WORKDIR}/${P/_rc/-rc}
+
# Allow for custion repository locations.
# This can't be in pkg_setup because the variable needs to be available to
# pkg_config.
diff --git a/dev-util/subversion/subversion-1.1.3-r1.ebuild b/dev-util/subversion/subversion-1.1.3-r1.ebuild
index c84e15756cb4..c717ebf1a8a8 100644
--- a/dev-util/subversion/subversion-1.1.3-r1.ebuild
+++ b/dev-util/subversion/subversion-1.1.3-r1.ebuild
@@ -1,22 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.3-r1.ebuild,v 1.3 2005/02/15 08:47:22 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.3-r1.ebuild,v 1.4 2005/02/24 01:42:35 vapier Exp $
inherit elisp-common libtool python eutils bash-completion flag-o-matic
DESCRIPTION="A compelling replacement for CVS"
-SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
HOMEPAGE="http://subversion.tigris.org/"
+SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
-SLOT="0"
LICENSE="Apache-1.1"
-KEYWORDS="~x86 ~sparc ~amd64 ~hppa ~ppc64"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="ssl apache2 berkdb python emacs perl java nls"
-
RESTRICT="maketest"
-S=${WORKDIR}/${P/_rc/-rc}
-
# Presently subversion doesn't build with swig-1.3.22, bug 65424
RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
>=dev-libs/apr-util-0.9.5
@@ -26,12 +23,13 @@ RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
berkdb? ( =sys-libs/db-4* )
java? ( virtual/jdk )
emacs? ( virtual/emacs )"
-
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.59"
# Does not work because jikes is broken
# jikes? (dev-java/jikes)"
+S=${WORKDIR}/${P/_rc/-rc}
+
# Allow for custion repository locations.
# This can't be in pkg_setup because the variable needs to be available to
# pkg_config.
diff --git a/dev-util/subversion/subversion-1.1.3.ebuild b/dev-util/subversion/subversion-1.1.3.ebuild
index 05b250d85939..063aa510c269 100644
--- a/dev-util/subversion/subversion-1.1.3.ebuild
+++ b/dev-util/subversion/subversion-1.1.3.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.3.ebuild,v 1.3 2005/02/15 08:47:22 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.3.ebuild,v 1.4 2005/02/24 01:42:35 vapier Exp $
inherit elisp-common libtool python eutils bash-completion
DESCRIPTION="A compelling replacement for CVS"
-SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
HOMEPAGE="http://subversion.tigris.org/"
+SRC_URI="http://subversion.tigris.org/tarballs/${P/_rc/-rc}.tar.bz2"
-SLOT="0"
LICENSE="Apache-1.1"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~alpha ~hppa ~ppc64 ~ia64"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="ssl apache2 berkdb python emacs perl java nls"
-S=${WORKDIR}/${P/_rc/-rc}
-
# Presently subversion doesn't build with swig-1.3.22, bug 65424
RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
!apache2? ( !>=net-www/apache-2* )
@@ -25,12 +23,13 @@ RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
berkdb? ( =sys-libs/db-4* )
java? ( virtual/jdk )
emacs? ( virtual/emacs )"
-
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.59"
# Does not work because jikes is broken
# jikes? (dev-java/jikes)"
+S=${WORKDIR}/${P/_rc/-rc}
+
# Allow for custion repository locations.
# This can't be in pkg_setup because the variable needs to be available to
# pkg_config.