summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-02-12 08:54:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-02-12 08:54:07 +0000
commita8894c39f5014fd364b4e241b67729b3a660fec6 (patch)
tree4ee1927f76fabfdf0bf80494839113ba6ff418fb
parentVersion bump. Thanks hiyuh (bug #402807) (diff)
downloadgentoo-2-a8894c39f5014fd364b4e241b67729b3a660fec6.tar.gz
gentoo-2-a8894c39f5014fd364b4e241b67729b3a660fec6.tar.bz2
gentoo-2-a8894c39f5014fd364b4e241b67729b3a660fec6.zip
Version bump (bug #384037 by radhermit).
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/wxpython-2.9.3.1.ebuild155
2 files changed, 161 insertions, 1 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 2a4af8571e7a..c45c000ff53e 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.156 2012/01/08 21:04:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.157 2012/02/12 08:54:07 dirtyepic Exp $
+
+*wxpython-2.9.3.1 (12 Feb 2012)
+
+ 12 Feb 2012; Ryan Hill <dirtyepic@gentoo.org> +wxpython-2.9.3.1.ebuild:
+ Version bump (bug #384037 by radhermit).
08 Jan 2012; Markos Chandras <hwoarang@gentoo.org> wxpython-2.8.12.1.ebuild:
Fix a typo. Patch by Arfrever
diff --git a/dev-python/wxpython/wxpython-2.9.3.1.ebuild b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
new file mode 100644
index 000000000000..83e9fce2d4e3
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.9.3.1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.3.1.ebuild,v 1.1 2012/02/12 08:54:07 dirtyepic Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+WX_GTK_VER="2.9"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+
+inherit alternatives distutils eutils fdo-mime wxwidgets
+
+MY_P="${P/wxpython-/wxPython-src-}"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2
+ examples? ( mirror://sourceforge/wxpython/wxPython-demo-${PV}.tar.bz2 )"
+
+LICENSE="wxWinLL-3"
+SLOT="2.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cairo examples opengl"
+
+RDEPEND="
+ >=x11-libs/wxGTK-${PV}:${WX_GTK_VER}[opengl?,tiff,X]
+ dev-libs/glib:2
+ dev-python/setuptools
+ media-libs/libpng:0
+ media-libs/tiff:0
+ virtual/jpeg
+ x11-libs/gtk+:2
+ x11-libs/pango[X]
+ cairo? ( >=dev-python/pycairo-1.8.4 )
+ opengl? ( dev-python/pyopengl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/wxPython"
+DOC_S="${WORKDIR}/wxPython-${PV}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="wx-${PV%.*}-gtk2 wxversion.py"
+
+src_prepare() {
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-scripts.patch
+ # drop editra - we have it as a separate package now
+ epatch "${FILESDIR}"/${PN}-2.8.11-drop-editra.patch
+
+ if use examples; then
+ cd "${DOC_S}"
+ epatch "${FILESDIR}"/${PN}-${SLOT}-wxversion-demo.patch
+ fi
+
+ python_copy_sources
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ DISTUTILS_GLOBAL_OPTIONS=(
+ "* WX_CONFIG=${WX_CONFIG}"
+ "* WXPORT=gtk2"
+ "* UNICODE=1"
+ "* BUILD_GLCANVAS=$(use opengl && echo 1 || echo 0)"
+ )
+}
+
+distutils_src_install_post_hook() {
+ # Collision protection.
+ local file
+ for file in "$(distutils_get_intermediate_installation_image)${EPREFIX}/usr/bin/"*; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+}
+
+src_install() {
+ local file x
+
+ distutils_src_install
+
+ # this should be temporary
+ dobin "${S}"/scripts/pyslices || die
+ dobin "${S}"/scripts/pysliceshell || die
+
+ # Collision protection.
+ rename_files() {
+ for file in "${D}$(python_get_sitedir)/"wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}" || return 1
+ done
+ }
+ python_execute_function -q rename_files
+
+ dodoc "${S}"/docs/{CHANGES,PyManual,README,wxPackage,wxPythonManual}.txt
+
+ insinto /usr/share/applications
+ for x in {Py{AlaMode,Crust,Shell,Slices{,Shell}},XRCed}; do
+ newins "${S}"/distrib/${x}.desktop ${x}-${SLOT}.desktop
+ done
+ insinto /usr/share/pixmaps
+ newins "${S}"/wx/py/PyCrust_32.png PyCrust-${SLOT}.png
+ newins "${S}"/wx/py/PySlices_32.png PySlices-${SLOT}.png
+ newins "${S}"/wx/tools/XRCed/XRCed_32.png XRCed-${SLOT}.png
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/demo
+ dodir /usr/share/doc/${PF}/samples
+ cp -R "${DOC_S}"/demo/* "${D}"/usr/share/doc/${PF}/demo/ || die
+ cp -R "${DOC_S}"/samples/* "${D}"/usr/share/doc/${PF}/samples/ || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+
+ distutils_pkg_postinst
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers, see this site for instructions on using"
+ elog "2.8 or 2.9 with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ elog
+ if use examples; then
+ elog "The demo.py app which contains demo modules with"
+ elog "documentation and source code has been installed at"
+ elog "/usr/share/doc/${PF}/demo/demo.py"
+ elog
+ elog "More example apps and modules can be found in"
+ elog "/usr/share/doc/${PF}/samples/"
+ fi
+ echo
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+
+ create_symlinks() {
+ alternatives_auto_makesym "$(python_get_sitedir)/wx.pth" "$(python_get_sitedir)/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym "$(python_get_sitedir)/wxversion.py" "$(python_get_sitedir)/wxversion.py-[0-9].[0-9]"
+ }
+ python_execute_function -q create_symlinks
+}