summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-12 04:42:06 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-12 04:42:06 +0000
commita97b7e3e0ac8df7bb90d0a016a1f6b1cf3fcb697 (patch)
tree02229aadaf129428615ea732d8d6797309644ca1
parentNew package (diff)
downloadgentoo-2-a97b7e3e0ac8df7bb90d0a016a1f6b1cf3fcb697.tar.gz
gentoo-2-a97b7e3e0ac8df7bb90d0a016a1f6b1cf3fcb697.tar.bz2
gentoo-2-a97b7e3e0ac8df7bb90d0a016a1f6b1cf3fcb697.zip
New package
-rw-r--r--net-www/mod_scgi/ChangeLog10
-rw-r--r--net-www/mod_scgi/Manifest5
-rw-r--r--net-www/mod_scgi/files/20_mod_scgi.conf5
-rw-r--r--net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha11
-rw-r--r--net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild47
-rw-r--r--net-www/scgi/ChangeLog9
-rw-r--r--net-www/scgi/Manifest4
-rw-r--r--net-www/scgi/files/digest-scgi-1.2_alpha11
-rw-r--r--net-www/scgi/scgi-1.2_alpha1.ebuild21
9 files changed, 99 insertions, 4 deletions
diff --git a/net-www/mod_scgi/ChangeLog b/net-www/mod_scgi/ChangeLog
new file mode 100644
index 000000000000..8c3332072b68
--- /dev/null
+++ b/net-www/mod_scgi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/mod_scgi
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_scgi/ChangeLog,v 1.1 2003/08/12 04:40:48 g2boojum Exp $
+
+*mod_scgi-1.2_alpha1 (12 Aug 2003)
+
+ 12 Aug 2003; Grant Goodyear <g2boojum@gentoo.org>
+ mod_scgi-1.2_alpha1.ebuild:
+ New package
+
diff --git a/net-www/mod_scgi/Manifest b/net-www/mod_scgi/Manifest
index df6afa173985..5fa635679ccb 100644
--- a/net-www/mod_scgi/Manifest
+++ b/net-www/mod_scgi/Manifest
@@ -1,3 +1,4 @@
-MD5 6895fc0d9d65c0a2c65f01ec0fc645d6 .mod_scgi-1.2_alpha1.ebuild.swp 12288
-MD5 0f200994a1d5098336cb0baab84f5c93 mod_scgi-1.2_alpha1.ebuild 812
+MD5 c88cc1e17740d8b35139af7a915341a1 mod_scgi-1.2_alpha1.ebuild 1214
+MD5 094b07f31ed336f5bf553ca221162686 ChangeLog 349
MD5 fe6e3027503038b59f1e9b4ee2cb3baa files/digest-mod_scgi-1.2_alpha1 61
+MD5 3d1c20f03676d9a3da3d0fe3ea73720f files/20_mod_scgi.conf 118
diff --git a/net-www/mod_scgi/files/20_mod_scgi.conf b/net-www/mod_scgi/files/20_mod_scgi.conf
new file mode 100644
index 000000000000..126feefd3357
--- /dev/null
+++ b/net-www/mod_scgi/files/20_mod_scgi.conf
@@ -0,0 +1,5 @@
+<IfDefine MODSCGI>
+ <IfModule !mod_scgi.c>
+ LoadModule scgi_module extramodules/mod_scgi.so
+ <!IfModule>
+</IfDefine>
diff --git a/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1 b/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1
new file mode 100644
index 000000000000..818dbd4658ba
--- /dev/null
+++ b/net-www/mod_scgi/files/digest-mod_scgi-1.2_alpha1
@@ -0,0 +1 @@
+MD5 2bb8b05c3f771c25778c808ab0960580 scgi-1.2a1.tar.gz 17778
diff --git a/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild b/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild
new file mode 100644
index 000000000000..926c16cc09f2
--- /dev/null
+++ b/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_scgi/mod_scgi-1.2_alpha1.ebuild,v 1.1 2003/08/12 04:40:48 g2boojum Exp $
+
+P0=${P/mod_/}
+MY_P=${P0/_alpha/a}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Apache module for a Replacement for the CGI protocol that is similar to FastCGI"
+HOMEPAGE="http://www.mems-exchange.org/software/scgi/"
+SRC_URI="http://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="apache2"
+DEPEND="net-www/scgi
+ net-www/apache
+ apache2? ( >=net-www/apache-2 )"
+
+src_compile() {
+ if [ -z "`use apache2`" ]
+ then
+ cd apache1
+ make || die "apache1 mod_scgi make failed"
+ else
+ cd apache2
+ make || die "apache2 mod_scgi make failed"
+ fi
+}
+
+src_install() {
+ if [ -z "`use apache2`" ]
+ then
+ cd apache1
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/${PN}.so
+ dodoc README
+ insinto /etc/apache/conf/modules.d
+ doins ${FILESDIR}/20_mod_scgi.conf
+ else
+ cd apache2
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ dodoc README
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/20_mod_scgi.conf
+ fi
+}
diff --git a/net-www/scgi/ChangeLog b/net-www/scgi/ChangeLog
new file mode 100644
index 000000000000..f1b6c1788ea0
--- /dev/null
+++ b/net-www/scgi/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/scgi
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/scgi/ChangeLog,v 1.1 2003/08/12 04:42:02 g2boojum Exp $
+
+*scgi-1.2_alpha1 (12 Aug 2003)
+
+ 12 Aug 2003; Grant Goodyear <g2boojum@gentoo.org> scgi-1.2_alpha1.ebuild:
+ New package
+
diff --git a/net-www/scgi/Manifest b/net-www/scgi/Manifest
index 8e99b6097c2f..a0b20541e1d0 100644
--- a/net-www/scgi/Manifest
+++ b/net-www/scgi/Manifest
@@ -1,3 +1,3 @@
-MD5 e15cb1aa39908d8d1dbb88fceeb0aec8 .scgi-1.2_alpha1.ebuild.swp 16384
-MD5 edf9710d253da1b90fbaaa365026b012 scgi-1.2_alpha1.ebuild 521
+MD5 d16a5c7cc032df6464735fc89ea95fdc scgi-1.2_alpha1.ebuild 667
+MD5 ef1983e3dc3696042221abf71f20ec92 ChangeLog 331
MD5 fe6e3027503038b59f1e9b4ee2cb3baa files/digest-scgi-1.2_alpha1 61
diff --git a/net-www/scgi/files/digest-scgi-1.2_alpha1 b/net-www/scgi/files/digest-scgi-1.2_alpha1
new file mode 100644
index 000000000000..818dbd4658ba
--- /dev/null
+++ b/net-www/scgi/files/digest-scgi-1.2_alpha1
@@ -0,0 +1 @@
+MD5 2bb8b05c3f771c25778c808ab0960580 scgi-1.2a1.tar.gz 17778
diff --git a/net-www/scgi/scgi-1.2_alpha1.ebuild b/net-www/scgi/scgi-1.2_alpha1.ebuild
new file mode 100644
index 000000000000..ea2f21a7c339
--- /dev/null
+++ b/net-www/scgi/scgi-1.2_alpha1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/scgi/scgi-1.2_alpha1.ebuild,v 1.1 2003/08/12 04:42:02 g2boojum Exp $
+
+MY_P=${P/_alpha/a}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Replacement for the CGI protocol that is similar to FastCGI"
+HOMEPAGE="http://www.mems-exchange.org/software/scgi/"
+SRC_URI="http://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+inherit distutils
+
+pkg_postinst() {
+ einfo "This package does not install mod_scgi"
+ einfo "Please 'emerge mod_scgi' if you need it"
+}