summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-24 23:57:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-24 23:57:27 +0000
commitae6f76f3bca8e432a3b1e407874c6202e5a04165 (patch)
tree0885e5543e1647d9d2ca8c55e1fe35fd2939a95a
parentVersion bump. (diff)
downloadgentoo-2-ae6f76f3bca8e432a3b1e407874c6202e5a04165.tar.gz
gentoo-2-ae6f76f3bca8e432a3b1e407874c6202e5a04165.tar.bz2
gentoo-2-ae6f76f3bca8e432a3b1e407874c6202e5a04165.zip
Only enable Qt4 so far, bug 483648
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
-rw-r--r--media-libs/opencv/ChangeLog5
-rw-r--r--media-libs/opencv/opencv-2.4.8.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/media-libs/opencv/ChangeLog b/media-libs/opencv/ChangeLog
index 8f33b5923c96..79360b9c028d 100644
--- a/media-libs/opencv/ChangeLog
+++ b/media-libs/opencv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/opencv
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.105 2014/01/24 21:16:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.106 2014/01/24 23:57:27 dilfridge Exp $
+
+ 24 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org> opencv-2.4.8.ebuild:
+ Only enable Qt4 so far, bug 483648
*opencv-2.4.8 (24 Jan 2014)
diff --git a/media-libs/opencv/opencv-2.4.8.ebuild b/media-libs/opencv/opencv-2.4.8.ebuild
index b9bf88bd965b..49fad38473f4 100644
--- a/media-libs/opencv/opencv-2.4.8.ebuild
+++ b/media-libs/opencv/opencv-2.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/opencv-2.4.8.ebuild,v 1.1 2014/01/24 21:16:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/opencv-2.4.8.ebuild,v 1.2 2014/01/24 23:57:27 dilfridge Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -127,7 +127,6 @@ src_configure() {
$(cmake-utils_use_with png)
$(cmake-utils_use_build python opencv_python)
-DWITH_PVAPI=OFF # not packaged
- $(cmake-utils_use_with qt4 QT)
-DWITH_QUICKTIME=OFF
$(cmake-utils_use_with threads TBB)
$(cmake-utils_use_with tiff)
@@ -159,6 +158,12 @@ src_configure() {
-DOPENCV_EXTRA_FLAGS_RELEASE="" # black magic
)
+ if use qt4; then
+ mycmakeargs+=( "-DWITH_QT=4" )
+ else
+ mycmakeargs+=( "-DWITH_QT=OFF" )
+ fi
+
if use cuda; then
if [[ "$(gcc-version)" > "4.7" ]]; then
ewarn "CUDA and >=sys-devel/gcc-4.8 do not play well together. Disabling CUDA support."