summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-02 21:39:46 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-02 21:39:46 +0000
commitb0691d3c6391fce3d17b663917e19f2f22cb3dfa (patch)
tree64908c539a0a1cefe148edb26ae3060fc42612d5
parentRevert previous unit file change, bug 527614. (diff)
downloadgentoo-2-b0691d3c6391fce3d17b663917e19f2f22cb3dfa.tar.gz
gentoo-2-b0691d3c6391fce3d17b663917e19f2f22cb3dfa.tar.bz2
gentoo-2-b0691d3c6391fce3d17b663917e19f2f22cb3dfa.zip
Port to new python eclasses
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--media-sound/jokosher/ChangeLog10
-rw-r--r--media-sound/jokosher/jokosher-0.11.5-r1.ebuild64
2 files changed, 71 insertions, 3 deletions
diff --git a/media-sound/jokosher/ChangeLog b/media-sound/jokosher/ChangeLog
index 15defb541af0..8a26aad5b712 100644
--- a/media-sound/jokosher/ChangeLog
+++ b/media-sound/jokosher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/jokosher
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/ChangeLog,v 1.13 2012/10/25 20:36:08 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/ChangeLog,v 1.14 2014/12/02 21:39:46 pacho Exp $
+
+*jokosher-0.11.5-r1 (02 Dec 2014)
+
+ 02 Dec 2014; Pacho Ramos <pacho@gentoo.org> +jokosher-0.11.5-r1.ebuild:
+ Port to new python eclasses
25 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org> jokosher-0.11.1.ebuild,
jokosher-0.11.5.ebuild:
@@ -47,4 +52,3 @@
Initial commit for bug 141362, thanks to Denis Gubanov, Eric Anderson, James
Kirkham, Jose daLuz, Alex Rostovtsev and many others I missed to mention
here.
-
diff --git a/media-sound/jokosher/jokosher-0.11.5-r1.ebuild b/media-sound/jokosher/jokosher-0.11.5-r1.ebuild
new file mode 100644
index 000000000000..5fb7f029aac1
--- /dev/null
+++ b/media-sound/jokosher/jokosher-0.11.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/jokosher-0.11.5-r1.ebuild,v 1.1 2014/12/02 21:39:46 pacho Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL="yes"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 distutils-r1
+
+DESCRIPTION="A simple yet powerful multi-track studio"
+HOMEPAGE="http://www.jokosher.org"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+# NOTE: setuptools are a runtime requirement as the app
+# loads its extensions via pkg_resources
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-0.10.8:0.10[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ >=media-libs/gnonlin-0.10.9:0.10
+ >=media-libs/gst-plugins-good-0.10.6:0.10
+ >=media-libs/gst-plugins-bad-0.10.5:0.10
+ >=media-plugins/gst-plugins-alsa-0.10.14:0.10
+ >=media-plugins/gst-plugins-flac-0.10.6:0.10
+ gnome? ( >=media-plugins/gst-plugins-gnomevfs-0.10.14:0.10 )
+ >=media-plugins/gst-plugins-lame-0.10.6:0.10
+ >=media-plugins/gst-plugins-ogg-0.10.14:0.10
+ >=media-plugins/gst-plugins-vorbis-0.10.14:0.10
+ >=media-plugins/gst-plugins-ladspa-0.10.5:0.10
+ x11-themes/hicolor-icon-theme
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.11.1-update-database.patch \
+ "${FILESDIR}"/${P}-cairo.patch
+ gnome2_src_prepare
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}