summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-01-31 08:49:05 +0000
committerBen de Groot <yngwin@gentoo.org>2013-01-31 08:49:05 +0000
commitb070aeb495343c7139a727feac509ea75836d0fd (patch)
tree38b0962d4e45c5b9e1559cd87bcebf9ebb069700
parentBump for #435430 (diff)
downloadgentoo-2-b070aeb495343c7139a727feac509ea75836d0fd.tar.gz
gentoo-2-b070aeb495343c7139a727feac509ea75836d0fd.tar.bz2
gentoo-2-b070aeb495343c7139a727feac509ea75836d0fd.zip
Version bump, bug #454486. Thanks to Dennis Lan and Wang Jiajun for contributions.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--app-i18n/fcitx-configtool/ChangeLog10
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/app-i18n/fcitx-configtool/ChangeLog b/app-i18n/fcitx-configtool/ChangeLog
index dba6e9e7fd4f..19b24c77124c 100644
--- a/app-i18n/fcitx-configtool/ChangeLog
+++ b/app-i18n/fcitx-configtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/fcitx-configtool
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/ChangeLog,v 1.14 2012/10/29 06:59:12 yngwin Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/ChangeLog,v 1.15 2013/01/31 08:49:05 yngwin Exp $
+
+*fcitx-configtool-0.4.6 (31 Jan 2013)
+
+ 31 Jan 2013; Ben de Groot <yngwin@gentoo.org> +fcitx-configtool-0.4.6.ebuild:
+ Version bump, bug #454486. Thanks to Dennis Lan and Wang Jiajun for
+ contributions.
29 Oct 2012; Ben de Groot <yngwin@gentoo.org> -fcitx-configtool-0.1.4.ebuild,
-fcitx-configtool-0.4.4.ebuild:
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild
new file mode 100644
index 000000000000..006a76fff6ee
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild,v 1.1 2013/01/31 08:49:05 yngwin Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A GTK+ GUI configuration tool for fcitx"
+HOMEPAGE="https://fcitx.googlecode.com/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk +gtk3"
+REQUIRED_USE="|| ( gtk gtk3 )"
+
+RDEPEND=">=app-i18n/fcitx-4.2.7
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}