summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 22:52:04 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 22:52:04 +0000
commitb44513a40c0de9661015e6663b023ff4af3d7c67 (patch)
tree97acb149c61ef0216fdaa2d3443be310df7fab52
parentVersion bump (diff)
downloadgentoo-2-b44513a40c0de9661015e6663b023ff4af3d7c67.tar.gz
gentoo-2-b44513a40c0de9661015e6663b023ff4af3d7c67.tar.bz2
gentoo-2-b44513a40c0de9661015e6663b023ff4af3d7c67.zip
Version bump, adds support for cintiq companion (bug #540204, thanks to Chandler Paul).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
-rw-r--r--dev-libs/libwacom/ChangeLog11
-rw-r--r--dev-libs/libwacom/libwacom-0.11.ebuild47
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-libs/libwacom/ChangeLog b/dev-libs/libwacom/ChangeLog
index c06857502b02..c0ec0cec8156 100644
--- a/dev-libs/libwacom/ChangeLog
+++ b/dev-libs/libwacom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libwacom
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/ChangeLog,v 1.23 2014/10/25 10:21:40 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/ChangeLog,v 1.24 2015/02/17 22:52:04 tetromino Exp $
+
+*libwacom-0.11 (17 Feb 2015)
+
+ 17 Feb 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libwacom-0.11.ebuild:
+ Version bump, adds support for cintiq companion (bug #540204, thanks to
+ Chandler Paul).
*libwacom-0.10 (25 Oct 2014)
diff --git a/dev-libs/libwacom/libwacom-0.11.ebuild b/dev-libs/libwacom/libwacom-0.11.ebuild
new file mode 100644
index 000000000000..0b3811a716f2
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-0.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwacom/libwacom-0.11.ebuild,v 1.1 2015/02/17 22:52:04 tetromino Exp $
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ virtual/libgudev:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ if ! use doc; then
+ sed -e 's:^\(SUBDIRS = .* \)doc:\1:' -i Makefile.in || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ local udevdir="$(get_udevdir)"
+ dodir "${udevdir}/rules.d"
+ # generate-udev-rules must be run from inside tools directory
+ pushd tools > /dev/null
+ ./generate-udev-rules > "${ED}/${udevdir}/rules.d/65-libwacom.rules" ||
+ die "generating udev rules failed"
+ popd > /dev/null
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}