summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-01-04 23:13:29 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-01-04 23:13:29 +0000
commitb5e17cc1737efb4a334073f1a13a38a5695f9c50 (patch)
treee839540b1a3b660044faa8cd6f9d76a96991fd62
parentPruning old versions (diff)
downloadgentoo-2-b5e17cc1737efb4a334073f1a13a38a5695f9c50.tar.gz
gentoo-2-b5e17cc1737efb4a334073f1a13a38a5695f9c50.tar.bz2
gentoo-2-b5e17cc1737efb4a334073f1a13a38a5695f9c50.zip
Resolving a few bugs for shfs (#101091, #112874, #81581, #78387)
(Portage version: 2.1_pre3-r1)
-rw-r--r--net-fs/shfs/ChangeLog9
-rw-r--r--net-fs/shfs/Manifest3
-rw-r--r--net-fs/shfs/files/0.35/shfs-0.35-clean-inode-clear.patch20
-rw-r--r--net-fs/shfs/files/digest-shfs-0.35-r21
-rw-r--r--net-fs/shfs/shfs-0.35-r2.ebuild112
5 files changed, 144 insertions, 1 deletions
diff --git a/net-fs/shfs/ChangeLog b/net-fs/shfs/ChangeLog
index 0bccb2e56fc9..7b9c12bd9d11 100644
--- a/net-fs/shfs/ChangeLog
+++ b/net-fs/shfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/shfs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.23 2006/01/04 23:05:15 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.24 2006/01/04 23:13:29 compnerd Exp $
+
+*shfs-0.35-r2 (04 Jan 2006)
+
+ 04 Jan 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/0.35/shfs-0.35-clean-inode-clear.patch, +shfs-0.35-r2.ebuild:
+ Revbump to clean up some problems. Resolves bugs #78387, #81581, #112874,
+ #101091.
04 Jan 2006; Saleem Abdulrasool <compnerd@gentoo.org>
-files/shfs-amd64-makefile.patch,
diff --git a/net-fs/shfs/Manifest b/net-fs/shfs/Manifest
index 5d6190f2c85e..c8827515c4a4 100644
--- a/net-fs/shfs/Manifest
+++ b/net-fs/shfs/Manifest
@@ -1,11 +1,14 @@
MD5 50d138a1cc7faf74c2ee4e6f19d55b8d ChangeLog 3845
MD5 29b3f063e5feb8c259abc86d07f92f85 files/0.35/df.patch 1652
+MD5 47388261d70d4dc5210fd93021dc8479 files/0.35/shfs-0.35-clean-inode-clear.patch 496
MD5 aa8bade7210ab4840af4a009378a96c3 files/0.35/shfs-0.35-gcc4.patch 1008
MD5 e5f37f793e95acdfd8e89affe9949160 files/0.35/space_chars.patch 1276
MD5 29e5b080a1744f8283b8f55d5b904a60 files/0.35/uidgid32.patch 940
MD5 d9c3f912bc5642882b84fa7f3edd8db8 files/amd.conf 842
MD5 97e8d1e483ac538a072e0e82af787eeb files/amd.shfs 152
MD5 8bdaeb75d54befa6b5d6f2bfe6657a60 files/digest-shfs-0.35-r1 61
+MD5 8bdaeb75d54befa6b5d6f2bfe6657a60 files/digest-shfs-0.35-r2 61
MD5 bdf9a4a620ff5bcd7828251c144ec02b files/shfs.mount 1346
MD5 b66027267bc1b372e656d834984ad137 metadata.xml 316
MD5 7b0f99afbccc7ba0cb5199a72eb072b1 shfs-0.35-r1.ebuild 2862
+MD5 e1f3bcc1f4120a384e536b2e0db7c420 shfs-0.35-r2.ebuild 2647
diff --git a/net-fs/shfs/files/0.35/shfs-0.35-clean-inode-clear.patch b/net-fs/shfs/files/0.35/shfs-0.35-clean-inode-clear.patch
new file mode 100644
index 000000000000..0cc4b30889a3
--- /dev/null
+++ b/net-fs/shfs/files/0.35/shfs-0.35-clean-inode-clear.patch
@@ -0,0 +1,20 @@
+--- shfs/Linux-2.6/inode.c.orig 2006-01-04 16:23:11.000000000 -0600
++++ shfs/Linux-2.6/inode.c 2006-01-04 16:24:45.000000000 -0600
+@@ -8,6 +8,7 @@
+ #include <linux/modversions.h>
+ #endif
+
++#include <linux/version.h>
+ #include <linux/kernel.h>
+ #include <linux/module.h>
+ #include <linux/init.h>
+@@ -118,6 +119,9 @@
+ }
+ KMEM_FREE("inode", inode_cache, i);
+ out:
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
++ truncate_inode_pages(&inode->i_data, 0);
++#endif
+ clear_inode(inode);
+ }
+
diff --git a/net-fs/shfs/files/digest-shfs-0.35-r2 b/net-fs/shfs/files/digest-shfs-0.35-r2
new file mode 100644
index 000000000000..88af63ae5275
--- /dev/null
+++ b/net-fs/shfs/files/digest-shfs-0.35-r2
@@ -0,0 +1 @@
+MD5 016f49d71bc32eee2b5d11fc1600cfbe shfs-0.35.tar.gz 128656
diff --git a/net-fs/shfs/shfs-0.35-r2.ebuild b/net-fs/shfs/shfs-0.35-r2.ebuild
new file mode 100644
index 000000000000..594feab089a8
--- /dev/null
+++ b/net-fs/shfs/shfs-0.35-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/shfs-0.35-r2.ebuild,v 1.1 2006/01/04 23:13:29 compnerd Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Secure Shell File System"
+HOMEPAGE="http://shfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="amd doc"
+
+RDEPEND="virtual/modutils
+ net-misc/openssh
+ amd? ( net-fs/am-utils )"
+DEPEND="virtual/linux-sources
+ sys-apps/sed
+ ${RDEPEND}"
+PDEPEND="net-misc/x11-ssh-askpass"
+
+CONFIG_CHECK="@SH_FS:shfs"
+SH_FS_ERROR="SHFS is built into the kernel. Only userland utilities will be provided."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ # Setup the Kernel module build
+ BUILD_PARAMS="-j1 KERNEL_SOURCES=${KV_DIR}"
+
+ # List the kernel modules that will be built
+ MODULE_NAMES="shfs(misc/fs:${S}/shfs/Linux-${KV_MAJOR}.${KV_MINOR})"
+
+ case "${KV_MAJOR}.${KV_MINOR}" in
+ "2.4") BUILD_TARGETS="all" ;;
+ "2.6") BUILD_TARGETS="default" ;;
+ esac
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.35/*.patch
+
+ # Take care of 2.6 Kernels <= 2.6.6
+ if [[ "${KV_MAJOR}.${KV_MINOR}" == "2.6" ]] ; then
+ convert_to_m ${S}/shfs/Linux-2.6/Makefile
+ fi
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ cd ${S}/shfsmount
+ emake || die "failed to build userland utilities"
+}
+
+src_install() {
+ # Install kernel module
+ linux-mod_src_install
+
+ # Install userland utilities
+ cd ${S}/shfsmount
+ dobin shfsmount
+ dobin shfsumount
+
+ if use amd ; then
+ insinto /etc/amd
+ doins ${FILESDIR}/amd.conf
+ doins ${FILESDIR}/amd.shfs
+
+ exeinto /etc/amd
+ doexe ${FILESDIR}/shfs.mount
+ dosym /etc/amd/shfs.mount /etc/amd/shfs.unmount
+ fi
+
+ # Setup permissions
+ einfo "Setting SUID bit on /usr/bin executables..."
+ fperms 4511 /usr/bin/shfsmount
+ fperms 4511 /usr/bin/shfsumount
+
+ # Create symlinks to support mount(8)
+ einfo "Adding /sbin/mount.shfs symlink..."
+ dodir /sbin
+ dosym /usr/bin/shfsmount /sbin/mount.shfs
+
+ # Install docs
+ doman ${S}/docs/manpages/shfsmount.8 ${S}/docs/manpages/shfsumount.8
+ use doc && dohtml -r ${S}/docs/html
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ echo
+ einfo "Use either 'shfsmount' or 'mount -t shfs' to mount remote"
+ einfo "filesystems into your local filesystem."
+ echo
+ einfo "Note the following:"
+ einfo
+ einfo " 1. The shfs kernel module has to be loaded first before you can"
+ einfo " start mounting filesystems."
+ einfo " Try: 'modprobe shfs' as root."
+ einfo
+ einfo " 2. When mouting, you must enter the absolute path of the remote"
+ einfo " filesystem without any special characters such as tilde (~),"
+ einfo " for example as they will not be evaluated."
+ echo
+}