summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-17 11:56:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-17 11:56:43 +0000
commitba4ec8bc3fffd1c0d7e32f8f17cb7675e29a526d (patch)
tree40c3c22637c3651bafd84423e58ec7baa09fafef
parentFix translations generation snafu (diff)
downloadgentoo-2-ba4ec8bc3fffd1c0d7e32f8f17cb7675e29a526d.tar.gz
gentoo-2-ba4ec8bc3fffd1c0d7e32f8f17cb7675e29a526d.tar.bz2
gentoo-2-ba4ec8bc3fffd1c0d7e32f8f17cb7675e29a526d.zip
remove old
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--dev-ml/ocamlnet/ChangeLog6
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild75
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild78
3 files changed, 5 insertions, 154 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 93b9efab2b1b..021cc963ba69 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.89 2015/03/02 10:49:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.90 2015/03/17 11:56:43 aballier Exp $
+
+ 17 Mar 2015; Alexis Ballier <aballier@gentoo.org> -ocamlnet-3.7.3.ebuild,
+ -ocamlnet-4.0.1.ebuild:
+ remove old
*ocamlnet-4.0.2 (02 Mar 2015)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild
deleted file mode 100644
index 8d632ce5525b..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild,v 1.4 2014/02/14 13:03:57 nimiux Exp $
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5:= )
- >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
- cryptokit? ( dev-ml/cryptokit:= )
- gtk? ( >=dev-ml/lablgtk-2:= )
- ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
- zip? ( dev-ml/camlzip:= )
- "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable cryptokit crypto) \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable pcre pcre) \
- $(ocamlnet_use_enable ssl ssl) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild
deleted file mode 100644
index 149032ae5fac..000000000000
--- a/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-4.0.1.ebuild,v 1.1 2015/02/09 14:37:04 aballier Exp $
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-RDEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5:= )
- >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
- ssl? ( net-libs/gnutls:= )
- gtk? ( >=dev-ml/lablgtk-2:= )
- kerberos? ( virtual/krb5 )
- zip? ( dev-ml/camlzip:= )
- "
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
- if use $1; then
- echo "-with-$2"
- else
- echo "-without-$2"
- fi
-}
-
-ocamlnet_use_enable() {
- if use $1; then
- echo "-enable-$2"
- else
- echo "-disable-$2"
- fi
-}
-
-src_configure() {
- ./configure \
- -bindir /usr/bin \
- -datadir /usr/share/${PN} \
- $(ocamlnet_use_enable ssl gnutls) \
- $(ocamlnet_use_enable gtk gtk2) \
- $(ocamlnet_use_enable kerberos gssapi) \
- $(ocamlnet_use_enable pcre pcre) \
- $(ocamlnet_use_enable tk tcl) \
- $(ocamlnet_use_enable zip zip) \
- $(ocamlnet_use_with httpd nethttpd) \
- || die "Error : econf failed!"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt
- fi
-}
-
-src_install() {
- export STRIP_MASK="*/bin/*"
- findlib_src_install
-}