summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-30 15:58:53 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-30 15:58:53 +0000
commitbf5f96bcd1706aeebd77c214745c942b80481a72 (patch)
tree82ad1d8f60272ce529f20f537ffbd2a75980a360
parentStable for HPPA (bug #492282). (diff)
downloadgentoo-2-bf5f96bcd1706aeebd77c214745c942b80481a72.tar.gz
gentoo-2-bf5f96bcd1706aeebd77c214745c942b80481a72.tar.bz2
gentoo-2-bf5f96bcd1706aeebd77c214745c942b80481a72.zip
Add jruby. Drop test dependency on dev-ruby/rails:3.2 altogether since it will be masked soon.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/oauth/ChangeLog6
-rw-r--r--dev-ruby/oauth/oauth-0.4.7.ebuild17
2 files changed, 16 insertions, 7 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index b8fac9a2e46a..f9bcdd4aec86 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.21 2013/08/11 07:42:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.22 2013/11/30 15:58:53 graaff Exp $
+
+ 30 Nov 2013; Hans de Graaff <graaff@gentoo.org> oauth-0.4.7.ebuild:
+ Add jruby. Drop test dependency on dev-ruby/rails:3.2 altogether since it
+ will be masked soon.
11 Aug 2013; Hans de Graaff <graaff@gentoo.org> -oauth-0.4.6.ebuild:
Cleanup.
diff --git a/dev-ruby/oauth/oauth-0.4.7.ebuild b/dev-ruby/oauth/oauth-0.4.7.ebuild
index 19c927148e04..6a476b8c3267 100644
--- a/dev-ruby/oauth/oauth-0.4.7.ebuild
+++ b/dev-ruby/oauth/oauth-0.4.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.7.ebuild,v 1.1 2012/10/05 10:33:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.7.ebuild,v 1.2 2013/11/30 15:58:53 graaff Exp $
EAPI=4
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
RUBY_FAKEGEM_TASK_DOC=""
@@ -20,13 +20,19 @@ KEYWORDS="~amd64 ~x86 ~x86-macos"
IUSE=""
ruby_add_bdepend "test? (
- dev-ruby/mocha
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.12
dev-ruby/webmock )"
-USE_RUBY="ruby18 ree18" ruby_add_bdepend "test? ( >=dev-ruby/actionpack-2.3.8:2.3 )"
all_ruby_prepare() {
+ # Require a compatible version of mocha
+ sed -i -e '1igem "mocha", "~> 0.12.0"' test/test_helper.rb || die
+
# Ensure a consistent test order to avoid loading issues with e.g. rack
sed -i -e "s/.rb']/.rb'].sort/" Rakefile || die
+
+ # Remove tests that require Rails 2.3 since that is ruby18-only.
+ rm test/test_action_controller_request_proxy.rb || die
}
each_ruby_prepare() {
@@ -41,7 +47,6 @@ each_ruby_prepare() {
;;
*ruby19)
# Remove tests depending on rails.
- rm test/test_action_controller_request_proxy.rb || die
;;
*)
;;