summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-28 05:06:04 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-28 05:06:04 +0000
commitbf90d616d8b38ee94929398caae877ebeaf8ac18 (patch)
tree29b03c774723acda5a88e075ab577f4a3f9515bd
parentStable for HPPA (bug #525016). (diff)
downloadgentoo-2-bf90d616d8b38ee94929398caae877ebeaf8ac18.tar.gz
gentoo-2-bf90d616d8b38ee94929398caae877ebeaf8ac18.tar.bz2
gentoo-2-bf90d616d8b38ee94929398caae877ebeaf8ac18.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/bson/ChangeLog7
-rw-r--r--dev-ruby/bson/bson-3.2.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/bson/ChangeLog b/dev-ruby/bson/ChangeLog
index 548006a3a5b0..42a09efab4e1 100644
--- a/dev-ruby/bson/ChangeLog
+++ b/dev-ruby/bson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bson
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/ChangeLog,v 1.21 2015/06/08 19:14:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/ChangeLog,v 1.22 2015/07/28 05:06:04 graaff Exp $
+
+*bson-3.2.0 (28 Jul 2015)
+
+ 28 Jul 2015; Hans de Graaff <graaff@gentoo.org> +bson-3.2.0.ebuild:
+ Version bump.
08 Jun 2015; Hans de Graaff <graaff@gentoo.org> bson-3.0.4.ebuild:
Update SLOT to allow for a proper dependency in dev-ruby/mongo.
diff --git a/dev-ruby/bson/bson-3.2.0.ebuild b/dev-ruby/bson/bson-3.2.0.ebuild
new file mode 100644
index 000000000000..6904c0989264
--- /dev/null
+++ b/dev-ruby/bson/bson-3.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/bson-3.2.0.ebuild,v 1.1 2015/07/28 05:06:04 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+ruby_add_bdepend \
+ "test? (
+ dev-ruby/rake
+ dev-ruby/shoulda
+ dev-ruby/mocha
+ dev-ruby/test-unit:2
+ )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}