summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-05-24 18:47:10 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-05-24 18:47:10 +0000
commitc459393a7dcb96947482baf5cbafad7335badd0a (patch)
tree38c84d74f46e604e55f8d72f2fd696119d6f3cae
parentCall python_pkg_setup() instead of validate_PYTHON_ABIS(). (diff)
downloadgentoo-2-c459393a7dcb96947482baf5cbafad7335badd0a.tar.gz
gentoo-2-c459393a7dcb96947482baf5cbafad7335badd0a.tar.bz2
gentoo-2-c459393a7dcb96947482baf5cbafad7335badd0a.zip
Version bump. With many thanks to Oliver Jaksch, Stefan Knoblich, Jaco Kroon & Kerin Millar for research, patches & testing. Closes bug #315237.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--net-misc/dahdi/ChangeLog8
-rw-r--r--net-misc/dahdi/dahdi-2.3.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/net-misc/dahdi/ChangeLog b/net-misc/dahdi/ChangeLog
index ff26695bdb57..8b8f48b2143d 100644
--- a/net-misc/dahdi/ChangeLog
+++ b/net-misc/dahdi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dahdi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/ChangeLog,v 1.5 2010/05/18 14:28:06 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/ChangeLog,v 1.6 2010/05/24 18:47:10 chainsaw Exp $
+
+*dahdi-2.3.0 (24 May 2010)
+
+ 24 May 2010; <chainsaw@gentoo.org> +dahdi-2.3.0.ebuild:
+ Version bump. With many thanks to Oliver Jaksch, Stefan Knoblich, Jaco
+ Kroon & Kerin Millar for research, patches & testing. Closes bug #315237.
18 May 2010; <chainsaw@gentoo.org> dahdi-2.1.0.4.ebuild,
dahdi-2.2.0.2.ebuild, dahdi-2.2.1.1.ebuild:
diff --git a/net-misc/dahdi/dahdi-2.3.0.ebuild b/net-misc/dahdi/dahdi-2.3.0.ebuild
new file mode 100644
index 000000000000..3b8f727812fc
--- /dev/null
+++ b/net-misc/dahdi/dahdi-2.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi/dahdi-2.3.0.ebuild,v 1.1 2010/05/24 18:47:10 chainsaw Exp $
+
+EAPI=3
+
+inherit base linux-mod eutils flag-o-matic
+
+MY_P="${P/dahdi/dahdi-linux}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Kernel modules for Digium compatible hardware (formerly known as Zaptel)."
+HOMEPAGE="http://www.asterisk.org"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/${MY_P}.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.20.0.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-oct6114-064-1.05.01.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-oct6114-128-1.05.01.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-tc400m-MR6.12.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.20.0.tar.gz
+http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fw-hx8-2.06.tar.gz
+mirror://gentoo/gentoo-dahdi-patchset-0.2.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+EPATCH_SUFFIX="diff"
+PATCHES=( "${WORKDIR}/dahdi-patchset" )
+
+src_unpack() {
+ unpack ${A}
+ # Copy the firmware tarballs over, the makefile will try and download them otherwise
+ for file in ${A} ; do
+ cp "${DISTDIR}"/${file} "${MY_P}"/drivers/dahdi/firmware/
+ done
+ # But without the .bin's it'll still fall over and die, so copy those too.
+ cp *.bin "${MY_P}"/drivers/dahdi/firmware/
+}
+
+src_compile() {
+ unset ARCH
+ emake KSRC="${KERNEL_DIR}" DESTDIR="${D}" all || die "Compilation failed"
+}
+
+src_install() {
+ # setup directory structure so udev rules get installed
+ mkdir -p "${D}"/etc/udev/rules.d
+
+ einfo "Installing kernel module"
+ emake KSRC="${KERNEL_DIR}" DESTDIR="${D}" install || die "Installation failed"
+ rm -rf "$D"/lib/modules/*/modules.*
+}