summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-19 09:22:15 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-19 09:22:15 +0000
commitc7e03a69a5f73673203893da4e17e509595e4bd6 (patch)
tree267395c6e90a8a3f39f5a4069292b655c869b1ce
parentReduce ffmpeg dep, bug #513752. (diff)
downloadgentoo-2-c7e03a69a5f73673203893da4e17e509595e4bd6.tar.gz
gentoo-2-c7e03a69a5f73673203893da4e17e509595e4bd6.tar.bz2
gentoo-2-c7e03a69a5f73673203893da4e17e509595e4bd6.zip
-remove old, fixes Bug #513662 by Monsieur L. Bachelier
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/irc/ChangeLog6
-rw-r--r--dev-python/irc/irc-8.5.1.ebuild45
-rw-r--r--dev-python/irc/irc-8.5.3.ebuild45
-rw-r--r--dev-python/irc/irc-8.5.4.ebuild46
-rw-r--r--dev-python/irc/irc-8.9.ebuild46
5 files changed, 5 insertions, 183 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
index 80f47e1e85b0..e4124ed1c790 100644
--- a/dev-python/irc/ChangeLog
+++ b/dev-python/irc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/irc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.24 2014/06/12 06:51:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.25 2014/06/19 09:22:15 idella4 Exp $
+
+ 19 Jun 2014; Ian Delaney <idella4@gentoo.org> -irc-8.5.1.ebuild,
+ -irc-8.5.3.ebuild, -irc-8.5.4.ebuild, -irc-8.9.ebuild:
+ -remove old, fixes Bug #513662 by Monsieur L. Bachelier
12 Jun 2014; Patrick Lauer <patrick@gentoo.org> irc-8.9.1.ebuild:
Add py34 support
diff --git a/dev-python/irc/irc-8.5.1.ebuild b/dev-python/irc/irc-8.5.1.ebuild
deleted file mode 100644
index fa9ee9787dc7..000000000000
--- a/dev-python/irc/irc-8.5.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.1.ebuild,v 1.3 2014/03/31 21:20:18 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python."
-HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-DEPEND="app-arch/unzip
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/irc-8.5.1-setup_requires.patch"
-)
-
-python_prepare_all() {
- # Don't rely on hgtools for version
- sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
- sed -e "/^tag_/d" -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test irc/tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( scripts/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/irc-8.5.3.ebuild b/dev-python/irc/irc-8.5.3.ebuild
deleted file mode 100644
index 8f3f93f5e367..000000000000
--- a/dev-python/irc/irc-8.5.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.3.ebuild,v 1.2 2014/03/31 21:20:18 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python."
-HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-DEPEND="app-arch/unzip
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/irc-8.5.1-setup_requires.patch"
-)
-
-python_prepare_all() {
- # Don't rely on hgtools for version
- sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
- sed -e "/^tag_/d" -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test irc/tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( scripts/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/irc-8.5.4.ebuild b/dev-python/irc/irc-8.5.4.ebuild
deleted file mode 100644
index 287ed67f29a1..000000000000
--- a/dev-python/irc/irc-8.5.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.4.ebuild,v 1.4 2014/04/11 03:01:40 sdamashek Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python."
-HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/irc-8.5.1-setup_requires.patch"
-)
-
-python_prepare_all() {
- # Don't rely on hgtools for version
- sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
- sed -e "/^tag_/d" -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test irc/tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( scripts/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/irc/irc-8.9.ebuild b/dev-python/irc/irc-8.9.ebuild
deleted file mode 100644
index 149646c9813c..000000000000
--- a/dev-python/irc/irc-8.9.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.9.ebuild,v 1.1 2014/05/12 08:05:38 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python."
-HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/irc-8.5.1-setup_requires.patch"
-)
-
-python_prepare_all() {
- # Don't rely on hgtools for version
- sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
- sed -e "/^tag_/d" -i setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test irc/tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( scripts/. )
- distutils-r1_python_install_all
-}