summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-29 09:24:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-29 09:24:32 +0000
commitcd8b8704ace2bcc728cfd51a9ec2d580a09bdf1e (patch)
treeef384f09a3d5a81264f5d4c2f4b652a7ef255664
parentStable for sparc, wrt bug #510342 (diff)
downloadgentoo-2-cd8b8704ace2bcc728cfd51a9ec2d580a09bdf1e.tar.gz
gentoo-2-cd8b8704ace2bcc728cfd51a9ec2d580a09bdf1e.tar.bz2
gentoo-2-cd8b8704ace2bcc728cfd51a9ec2d580a09bdf1e.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--dev-ml/lwt/ChangeLog9
-rw-r--r--dev-ml/lwt/lwt-2.4.6.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ml/lwt/ChangeLog b/dev-ml/lwt/ChangeLog
index 0b8e0ad6054a..2e57faa9409a 100644
--- a/dev-ml/lwt/ChangeLog
+++ b/dev-ml/lwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lwt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.27 2013/08/19 13:06:38 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.28 2014/10/29 09:24:32 aballier Exp $
+
+*lwt-2.4.6 (29 Oct 2014)
+
+ 29 Oct 2014; Alexis Ballier <aballier@gentoo.org> +lwt-2.4.6.ebuild:
+ version bump
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> lwt-2.4.3.ebuild,
+files/lwt-2.4.3-ocaml-4.01.patch:
diff --git a/dev-ml/lwt/lwt-2.4.6.ebuild b/dev-ml/lwt/lwt-2.4.6.ebuild
new file mode 100644
index 000000000000..280d2dabe1b5
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-2.4.6.ebuild,v 1.1 2014/10/29 09:24:32 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( >=dev-ml/react-1.2:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+DOCS=( "CHANGES" "README" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)
+ --disable-ppx" \
+ oasis_src_configure
+}