summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-11-13 22:54:40 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-11-13 22:54:40 +0000
commitd3e4251f6b3bec3f4849b42c996040571af695db (patch)
treea9495e4334272bfab4ff4be3f9eed288b8d7584a
parentStable on x86 wrt bug #198866 (diff)
downloadgentoo-2-d3e4251f6b3bec3f4849b42c996040571af695db.tar.gz
gentoo-2-d3e4251f6b3bec3f4849b42c996040571af695db.tar.bz2
gentoo-2-d3e4251f6b3bec3f4849b42c996040571af695db.zip
Version bump for testing. Closing bug #197572.
(Portage version: 2.1.3.19)
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.5_pre5.ebuild75
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.5_pre53
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index f04932ab4f4c..599eea581076 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.174 2007/10/12 00:09:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.175 2007/11/13 22:54:39 wolf31o2 Exp $
+
+*catalyst-2.0.5_pre5 (13 Nov 2007)
+
+ 13 Nov 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.5_pre5.ebuild:
+ Version bump for testing. Closing bug #197572.
*catalyst-2.0.5_pre4 (12 Oct 2007)
diff --git a/dev-util/catalyst/catalyst-2.0.5_pre5.ebuild b/dev-util/catalyst/catalyst-2.0.5_pre5.ebuild
new file mode 100644
index 000000000000..7356c547b697
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.5_pre5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.5_pre5.ebuild,v 1.1 2007/11/13 22:54:39 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.5_pre5 b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre5
new file mode 100644
index 000000000000..3c2165a2ef42
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre5
@@ -0,0 +1,3 @@
+MD5 5ac23caec7d9128900ed5d84ef1ec578 catalyst-2.0.5_pre5.tar.bz2 788396
+RMD160 51d457fc23eb343a8a829896b9c76e524478933f catalyst-2.0.5_pre5.tar.bz2 788396
+SHA256 52635cd1980ace61ed952e922a1fdbf2928b86c2de07d5f6a7a04e6353f84d06 catalyst-2.0.5_pre5.tar.bz2 788396