summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-22 05:57:52 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-22 05:57:52 +0000
commitd3f8b9e316962b1a66b860da66bf1dbf8cdc2766 (patch)
tree4497ab24174be1b75c2d70ad8b26364495917810
parentVersion bump. (diff)
downloadgentoo-2-d3f8b9e316962b1a66b860da66bf1dbf8cdc2766.tar.gz
gentoo-2-d3f8b9e316962b1a66b860da66bf1dbf8cdc2766.tar.bz2
gentoo-2-d3f8b9e316962b1a66b860da66bf1dbf8cdc2766.zip
initial havana keystone :D
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--sys-auth/keystone/ChangeLog8
-rw-r--r--sys-auth/keystone/keystone-2013.2.9999.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 288eec9a6f24..60d950a5c38b 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.39 2013/10/19 08:12:03 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.40 2013/10/22 05:57:52 prometheanfire Exp $
+
+*keystone-2013.2.9999 (22 Oct 2013)
+
+ 22 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +keystone-2013.2.9999.ebuild:
+ initial havana keystone :D
19 Oct 2013; Ian Delaney <idella4@gentoo.org> keystone-2013.1.3-r3.ebuild:
Cited bug citing bug filed upstream re test failure issue
diff --git a/sys-auth/keystone/keystone-2013.2.9999.ebuild b/sys-auth/keystone/keystone-2013.2.9999.ebuild
new file mode 100644
index 000000000000..391b9ad5a522
--- /dev/null
+++ b/sys-auth/keystone/keystone-2013.2.9999.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.2.9999.ebuild,v 1.1 2013/10/22 05:57:52 prometheanfire Exp $
+
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-2 distutils-r1
+
+DESCRIPTION="Keystone is the Openstack authentication, authorization, and
+service catalog written in Python."
+HOMEPAGE="https://launchpad.net/keystone"
+EGIT_REPO_URI="https://github.com/openstack/keystone.git"
+EGIT_BRANCH="stable/havana"
+
+LICENSE="Apache-2.0"
+SLOT="grizzly"
+KEYWORDS=""
+IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+#todo, seperate out rdepend via use flags
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
+ <dev-python/webob-1.3[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.0[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+
+#PATCHES=(
+# "${FILESDIR}/2013.1.3-CVE-2013-4222.patch"
+#)
+
+python_install() {
+ distutils-r1_python_install
+ newconfd "${FILESDIR}/keystone.confd" keystone
+ newinitd "${FILESDIR}/keystone.initd" keystone
+
+ diropts -m 0750
+ dodir /var/run/keystone /var/log/keystone /etc/keystone
+ keepdir /etc/keystone
+ insinto /etc/keystone
+ doins etc/keystone.conf.sample etc/logging.conf.sample
+ doins etc/default_catalog.templates etc/policy.json
+}