summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-23 02:44:41 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-23 02:44:41 +0000
commitda1b7ed9c7feea912d74351b23f3eb01fb71ccc2 (patch)
treeb1b993e9940777528bbedf0f8e7e8bd02e11f39e
parentVersion bump. (diff)
downloadgentoo-2-da1b7ed9c7feea912d74351b23f3eb01fb71ccc2.tar.gz
gentoo-2-da1b7ed9c7feea912d74351b23f3eb01fb71ccc2.tar.bz2
gentoo-2-da1b7ed9c7feea912d74351b23f3eb01fb71ccc2.zip
Version bump.
(Portage version: 2.1.2.7)
-rw-r--r--kde-base/quanta/ChangeLog7
-rw-r--r--kde-base/quanta/files/digest-quanta-3.5.73
-rw-r--r--kde-base/quanta/quanta-3.5.7.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/quanta/ChangeLog b/kde-base/quanta/ChangeLog
index e30f2da7a44d..909b6b3aaa96 100644
--- a/kde-base/quanta/ChangeLog
+++ b/kde-base/quanta/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/quanta
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.68 2007/04/15 18:34:03 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/ChangeLog,v 1.69 2007/05/23 02:44:41 carlo Exp $
+
+*quanta-3.5.7 (23 May 2007)
+
+ 23 May 2007; Carsten Lohrke <carlo@gentoo.org> +quanta-3.5.7.ebuild:
+ Version bump.
15 Apr 2007; Wulf C. Krueger <philantrop@gentoo.org> quanta-3.5.6.ebuild:
Removed some bogus RDEPENDS and added a post-install, fixes bugs 101882
diff --git a/kde-base/quanta/files/digest-quanta-3.5.7 b/kde-base/quanta/files/digest-quanta-3.5.7
new file mode 100644
index 000000000000..b6cdad427a73
--- /dev/null
+++ b/kde-base/quanta/files/digest-quanta-3.5.7
@@ -0,0 +1,3 @@
+MD5 1329e0aea45947a14faa3d936f9edb5d kdewebdev-3.5.7.tar.bz2 6046289
+RMD160 b1b8aa641e4e1dfe5be8af5b30b9cf910c8957d7 kdewebdev-3.5.7.tar.bz2 6046289
+SHA256 bf3a87156aa8aaaf721d9295c273afe0119af1dccf27d1fc360cbbeff68d489c kdewebdev-3.5.7.tar.bz2 6046289
diff --git a/kde-base/quanta/quanta-3.5.7.ebuild b/kde-base/quanta/quanta-3.5.7.ebuild
new file mode 100644
index 000000000000..ee9fac29680e
--- /dev/null
+++ b/kde-base/quanta/quanta-3.5.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.5.7.ebuild,v 1.1 2007/05/23 02:44:41 carlo Exp $
+KMNAME=kdewebdev
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc kdehiddenvisibility"
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${RDEPEND}
+doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+ kde-meta_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ echo
+ elog "${P} has some optional dependencies which you might want to emerge:"
+ elog "- app-text/htmltidy for HTML syntax checking."
+ elog "- app-crypt/gnupg for previewing browser configuration."
+ elog "- kde-base/kompare for comparing files by content."
+ elog "- kde-base/cervisia for enabling the CVS management plugin."
+ elog "- kde-base/kfilereplace for searching and replacing in files."
+ elog "- kde-base/kimagemapeditor for editing HTML image maps."
+ elog "- kde-base/klinkstatus for link validity checking."
+ elog "- kde-base/kxsldbg for XSLT debugging."
+ elog "- kde-base/kommander for the QuickStart dialogue and other scripted dialogues."
+ echo
+}