summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2005-01-25 20:28:28 +0000
committerChristian Birchinger <joker@gentoo.org>2005-01-25 20:28:28 +0000
commitdf20c7aefaed727ee76bb870bf17b8bf863bd9a1 (patch)
tree0165b006a30318f30f94f4a5217e25ecba6ecba3
parentVersion bump. Added commands to install all docs and modules (thanks to James... (diff)
downloadgentoo-2-df20c7aefaed727ee76bb870bf17b8bf863bd9a1.tar.gz
gentoo-2-df20c7aefaed727ee76bb870bf17b8bf863bd9a1.tar.bz2
gentoo-2-df20c7aefaed727ee76bb870bf17b8bf863bd9a1.zip
Version bump
(Portage version: 2.0.51-r15)
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.292
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 14c389d826fe..a5c1cd2900a1 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.76 2005/01/16 14:44:21 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.77 2005/01/25 20:28:28 joker Exp $
+
+*sparc-sources-2.4.29 (25 Jan 2005)
+
+ 25 Jan 2005; Christian Birchinger <joker@gentoo.org>
+ +sparc-sources-2.4.29.ebuild:
+ Version bump
*sparc-sources-2.4.28-r6 (16 Jan 2005)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29
new file mode 100644
index 000000000000..8411be570369
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29
@@ -0,0 +1,2 @@
+MD5 fcf8b6bb620467f27b657c1c4a60bbff linux-2.4.29.tar.bz2 31124710
+MD5 e19cf457095186f372b92fbe84042792 patches-2.4.29-sparc.tar.bz2 184046
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild
new file mode 100644
index 000000000000..b0610fb21f92
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild,v 1.1 2005/01/25 20:28:28 joker Exp $
+
+ETYPE="sources"
+IUSE="ultra1"
+inherit kernel-2
+detect_version
+
+PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
+
+SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
+
+KEYWORDS="-* ~sparc"
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
+SRC_URI="${KERNEL_URI} ${SSV_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
+
+pkg_setup() {
+ use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ if [ ! -r "/proc/openprom/name" -o "at /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+
+}