summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-03 12:37:31 +0000
committerMark Wright <gienah@gentoo.org>2014-07-03 12:37:31 +0000
commite99001f6f5b1f183b6c5ad9803610b3b5138c552 (patch)
tree0b19f6982f679d4f84e8eb38177ab2528aa066f8
parentBump hdbc-postgresql to 2.3.2.2-r2 (diff)
downloadgentoo-2-e99001f6f5b1f183b6c5ad9803610b3b5138c552.tar.gz
gentoo-2-e99001f6f5b1f183b6c5ad9803610b3b5138c552.tar.bz2
gentoo-2-e99001f6f5b1f183b6c5ad9803610b3b5138c552.zip
Fix Bug 514342 - dev-haskell/hdbc-mysql-0.6.6.1-r1 fails to build, based on the hdbc-postgresql patch by gracjan. Add virtual/mysql as suggested by grknight.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/hdbc-mysql/ChangeLog12
-rw-r--r--dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch33
-rw-r--r--dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild34
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-haskell/hdbc-mysql/ChangeLog b/dev-haskell/hdbc-mysql/ChangeLog
index 15ef668ebb54..297fe7aff92c 100644
--- a/dev-haskell/hdbc-mysql/ChangeLog
+++ b/dev-haskell/hdbc-mysql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-haskell/hdbc-mysql
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-mysql/ChangeLog,v 1.5 2013/03/17 16:10:53 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-mysql/ChangeLog,v 1.6 2014/07/03 12:37:30 gienah Exp $
+
+*hdbc-mysql-0.6.6.1-r2 (03 Jul 2014)
+
+ 03 Jul 2014; Mark Wright <gienah@gentoo.org>
+ +files/hdbc-mysql-0.6.6.1-cabal-1.18.patch, +hdbc-mysql-0.6.6.1-r2.ebuild:
+ Fix Bug 514342 - dev-haskell/hdbc-mysql-0.6.6.1-r1 fails to build, based on
+ the hdbc-postgresql patch by gracjan. Add virtual/mysql as suggested by
+ grknight.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch
new file mode 100644
index 000000000000..83ddd4a4c8ca
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/files/hdbc-mysql-0.6.6.1-cabal-1.18.patch
@@ -0,0 +1,33 @@
+--- HDBC-mysql-0.6.6.1-orig/Setup.lhs 2012-08-30 13:40:03.000000000 +1000
++++ HDBC-mysql-0.6.6.1/Setup.lhs 2014-07-03 22:31:21.162259637 +1000
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env runhaskell
+
+ \begin{code}
++{-# LANGUAGE MultiParamTypeClasses, FlexibleInstances #-}
+ import Distribution.Simple
+ import Distribution.PackageDescription
+ import Distribution.Version
+@@ -26,8 +27,21 @@
+ }
+ }
+
++-- 'ConstOrId' is a @Cabal-1.16@ vs @Cabal-1.18@ compatibility hack,
++-- 'programFindLocation' has a new (unused in this case)
++-- parameter. 'ConstOrId' adds this parameter when types say it is
++-- mandatory.
++class ConstOrId a b where
++ constOrId :: a -> b
++
++instance ConstOrId a a where
++ constOrId = id
++
++instance ConstOrId a (b -> a) where
++ constOrId = const
++
+ mysqlConfigProgram = (simpleProgram "mysql_config") {
+- programFindLocation = \verbosity -> do
++ programFindLocation = \verbosity -> constOrId $ do
+ mysql_config <- findProgramOnPath "mysql_config" verbosity
+ mysql_config5 <- findProgramOnPath "mysql_config5" verbosity
+ return (mysql_config `mplus` mysql_config5)
diff --git a/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild
new file mode 100644
index 000000000000..d739ce23d7a4
--- /dev/null
+++ b/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-mysql/hdbc-mysql-0.6.6.1-r2.ebuild,v 1.1 2014/07/03 12:37:30 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # workaround depend on old cabal-1.16
+inherit base haskell-cabal
+
+MY_PN="HDBC-mysql"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MySQL driver for HDBC"
+HOMEPAGE="http://github.com/bos/hdbc-mysql"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hdbc-2.1.0:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ virtual/mysql"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-0.6.6.1-cabal-1.18.patch")