summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-09 20:05:52 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-09 20:05:52 +0000
commitedf71bb975056586694b5d884a8de082a8385532 (patch)
tree45ef961f29a71b312193a42c00421890d45dd7f7
parentversion bump (diff)
downloadgentoo-2-edf71bb975056586694b5d884a8de082a8385532.tar.gz
gentoo-2-edf71bb975056586694b5d884a8de082a8385532.tar.bz2
gentoo-2-edf71bb975056586694b5d884a8de082a8385532.zip
Add virtual version for PyPy 2.0.2.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--virtual/pypy/ChangeLog7
-rw-r--r--virtual/pypy/pypy-2.0.2.ebuild22
2 files changed, 28 insertions, 1 deletions
diff --git a/virtual/pypy/ChangeLog b/virtual/pypy/ChangeLog
index 891e6cb612a8..fe2c65ffa0f4 100644
--- a/virtual/pypy/ChangeLog
+++ b/virtual/pypy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/pypy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/ChangeLog,v 1.3 2013/09/05 09:43:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/ChangeLog,v 1.4 2013/10/09 20:05:52 mgorny Exp $
+
+*pypy-2.0.2 (09 Oct 2013)
+
+ 09 Oct 2013; Michał Górny <mgorny@gentoo.org> +pypy-2.0.2.ebuild:
+ Add virtual version for PyPy 2.0.2.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> -pypy-1.9.ebuild:
Remove PyPy 1.9.
diff --git a/virtual/pypy/pypy-2.0.2.ebuild b/virtual/pypy/pypy-2.0.2.ebuild
new file mode 100644
index 000000000000..396da353163b
--- /dev/null
+++ b/virtual/pypy/pypy-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/pypy-2.0.2.ebuild,v 1.1 2013/10/09 20:05:52 mgorny Exp $
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="A virtual for PyPy Python implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT=$(get_version_component_range 1-2 ${PV})
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 ncurses sqlite"
+
+RDEPEND="
+ || (
+ >=dev-python/pypy-2.0.2:${SLOT}[bzip2?,ncurses?,sqlite?,ssl(+)]
+ >=dev-python/pypy-bin-2.0.2:${SLOT}[sqlite?]
+ )"