summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-27 04:46:43 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-27 04:46:43 +0000
commitf0d555dc827b2729c3e53fe7a1812c856acbc169 (patch)
tree7822a1f6070a0f3a043dbb623c4f837806497091
parentfix version dependencies. (diff)
downloadgentoo-2-f0d555dc827b2729c3e53fe7a1812c856acbc169.tar.gz
gentoo-2-f0d555dc827b2729c3e53fe7a1812c856acbc169.tar.bz2
gentoo-2-f0d555dc827b2729c3e53fe7a1812c856acbc169.zip
old
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.1.1-r29
-rw-r--r--sys-devel/gcc/gcc-4.1.1-r2.ebuild63
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-devel/gcc/files/digest-gcc-4.1.1-r2 b/sys-devel/gcc/files/digest-gcc-4.1.1-r2
deleted file mode 100644
index fb226caef52d..000000000000
--- a/sys-devel/gcc/files/digest-gcc-4.1.1-r2
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 0d051a3679b588208eb8ccbab313e81e gcc-4.1.1-patches-1.8.1.tar.bz2 51313
-RMD160 19848e779a60387e564135a8d9ab1870795d8914 gcc-4.1.1-patches-1.8.1.tar.bz2 51313
-SHA256 c146e6d82a1d07748c40f7686be2b21040a82f44ba5d8bfb234db102b6d77233 gcc-4.1.1-patches-1.8.1.tar.bz2 51313
-MD5 37396d61f74c49f68848f3e45e5e7d6c gcc-4.1.1-uclibc-patches-1.1.tar.bz2 20981
-RMD160 ca12459f3ec8ee8a9dc5c260bea4bb20d6a80a65 gcc-4.1.1-uclibc-patches-1.1.tar.bz2 20981
-SHA256 f97cf0f9fe52a529b41a78bb5d0d57899805fae00c3e7b2dff87c8192195b6f3 gcc-4.1.1-uclibc-patches-1.1.tar.bz2 20981
-MD5 ad9f97a4d04982ccf4fd67cb464879f3 gcc-4.1.1.tar.bz2 39172003
-RMD160 0edeac242d900b075a7e36796380492b5b3c8564 gcc-4.1.1.tar.bz2 39172003
-SHA256 985cbb23a486570a8783395a42a8689218f5218a0ccdd6bec590eef341367bb7 gcc-4.1.1.tar.bz2 39172003
diff --git a/sys-devel/gcc/gcc-4.1.1-r2.ebuild b/sys-devel/gcc/gcc-4.1.1-r2.ebuild
deleted file mode 100644
index 50b46204c58c..000000000000
--- a/sys-devel/gcc/gcc-4.1.1-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1-r2.ebuild,v 1.2 2006/11/17 00:03:51 vapier Exp $
-
-PATCH_VER="1.8.1"
-UCLIBC_VER="1.1"
-
-ETYPE="gcc-compiler"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-* ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
- virtual/libiconv
- fortran? (
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.2.0_p10
- )
- !build? (
- gcj? (
- gtk? (
- || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- # Fix cross-compiling
- epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
-
- epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-fast-math-i386-Os-workaround.patch
-}