summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-05 21:26:20 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-05 21:26:20 +0000
commitf45733846b33b37b7a45e0dda8dfdde7d3c1407e (patch)
tree561f888849a19551b363d0a4888b547382a6dec9
parentOptional static build for system recovery, helped me save some data (diff)
downloadgentoo-2-f45733846b33b37b7a45e0dda8dfdde7d3c1407e.tar.gz
gentoo-2-f45733846b33b37b7a45e0dda8dfdde7d3c1407e.tar.bz2
gentoo-2-f45733846b33b37b7a45e0dda8dfdde7d3c1407e.zip
Bump EAPI, migrate to python-single-r1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
-rw-r--r--kde-misc/ksplasher/ChangeLog8
-rw-r--r--kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild26
2 files changed, 19 insertions, 15 deletions
diff --git a/kde-misc/ksplasher/ChangeLog b/kde-misc/ksplasher/ChangeLog
index f1f6b49bd76e..19ec5724c2f1 100644
--- a/kde-misc/ksplasher/ChangeLog
+++ b/kde-misc/ksplasher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/ksplasher
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ChangeLog,v 1.4 2013/09/09 04:20:15 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ChangeLog,v 1.5 2014/01/05 21:26:20 creffett Exp $
+
+ 05 Jan 2014; Chris Reffett <creffett@gentoo.org>
+ ksplasher-2.0_beta2-r2.ebuild:
+ Bump EAPI, migrate to python-single-r1
*ksplasher-2.0_beta2-r2 (09 Sep 2013)
diff --git a/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild b/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild
index e1aef86be81a..0a06614fb448 100644
--- a/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild
+++ b/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild,v 1.1 2013/09/09 04:20:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ksplasher-2.0_beta2-r2.ebuild,v 1.2 2014/01/05 21:26:20 creffett Exp $
-EAPI=2
-PYTHON_DEPEND="2"
-inherit python eutils
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit python-single-r1 eutils
-DESCRIPTION="a KSplashX engine (KDE4) Splash Screen Creator"
+DESCRIPTION="A KSplashX engine (KDE4) Splash Screen Creator"
HOMEPAGE="http://ksplasher.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}x${PV/_}.tar.gz"
@@ -15,18 +15,17 @@ SLOT="4"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-python/imaging
- dev-python/PyQt4"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/imaging[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S=${WORKDIR}/${PN}x
-pkg_setup() {
- python_set_active_version 2
-}
-
src_prepare() {
epatch "${FILESDIR}/${PN}-pillow.patch"
- python_convert_shebangs -r 2 .
# ksplasherx is a bash script which calls 'python foo'. We fix it here.
sed -i -e 's:python:/usr/bin/env python2:g' ksplasherx || die
}
@@ -35,6 +34,7 @@ src_install() {
dobin ksplasherx || die
insinto /usr/share/ksplasherx
doins -r src || die
+ python_fix_shebang "${ED}/usr/share/ksplasherx/src/"
doicon ksicon.png
make_desktop_entry ${PN}x KSplasherX ksicon "Qt;KDE;Graphics"
dodoc README