summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-20 07:50:15 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-20 07:50:15 +0000
commitf4d7c8e8569e9171cdc375e28b4c27d28b165889 (patch)
tree6bec1385930d60909ec8e8491260711e5c123401
parentdev-lang/tcl: Drop old; drop notification about threading support in favour o... (diff)
downloadgentoo-2-f4d7c8e8569e9171cdc375e28b4c27d28b165889.tar.gz
gentoo-2-f4d7c8e8569e9171cdc375e28b4c27d28b165889.tar.bz2
gentoo-2-f4d7c8e8569e9171cdc375e28b4c27d28b165889.zip
sys-process/numad: Respect CC and CFLAGS as upstream recommends, #429508
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--sys-process/numad/ChangeLog10
-rw-r--r--sys-process/numad/metadata.xml10
-rw-r--r--sys-process/numad/numad-0.5-r1.ebuild45
-rw-r--r--sys-process/numad/numad-9999.ebuild18
4 files changed, 68 insertions, 15 deletions
diff --git a/sys-process/numad/ChangeLog b/sys-process/numad/ChangeLog
index a4980a7ae6e5..eb4dfb533ffc 100644
--- a/sys-process/numad/ChangeLog
+++ b/sys-process/numad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/numad
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/ChangeLog,v 1.5 2013/02/27 00:28:26 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/ChangeLog,v 1.6 2014/01/20 07:50:15 jlec Exp $
+
+*numad-0.5-r1 (20 Jan 2014)
+
+ 20 Jan 2014; Justin Lecher <jlec@gentoo.org> +numad-0.5-r1.ebuild,
+ numad-9999.ebuild, metadata.xml:
+ Respect CC and CFLAGS as upstream recommends, #429508
27 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org> numad-9999.ebuild:
fix PV check; empty KEYWORDS
diff --git a/sys-process/numad/metadata.xml b/sys-process/numad/metadata.xml
index 44551a5a563c..6565d583883d 100644
--- a/sys-process/numad/metadata.xml
+++ b/sys-process/numad/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>base-system</herd>
- <maintainer>
- <email>cardoe@gentoo.org</email>
- <name>Doug Goldstein</name>
- </maintainer>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-process/numad/numad-0.5-r1.ebuild b/sys-process/numad/numad-0.5-r1.ebuild
new file mode 100644
index 000000000000..f91afeafaa41
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-0.5-r1.ebuild,v 1.1 2014/01/20 07:50:15 jlec Exp $
+
+EAPI=5
+
+inherit linux-info toolchain-funcs
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ KEYWORDS="~amd64 -arm -s390 ~x86"
+else
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ KEYWORDS="~amd64 -arm -s390 ~x86"
+ S="${WORKDIR}/${PN}-334278f"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index 95c491bf6217..c80d2bb32736 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-9999.ebuild,v 1.2 2013/02/27 00:28:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-9999.ebuild,v 1.3 2014/01/20 07:50:15 jlec Exp $
-EAPI=4
+EAPI=5
-inherit linux-info git-2
+inherit git-r3 linux-info toolchain-funcs
if [[ ${PV} = "9999" ]]; then
inherit git-2
@@ -17,26 +17,28 @@ fi
DESCRIPTION="The NUMA daemon that manages application locality"
HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
-#SRC_URI=""
LICENSE="LGPL-2.1"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
epatch
+
+ tc-export CC
}
src_configure() {
:
}
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
src_install() {
emake prefix="${ED}/usr" install
}