summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-09-03 14:39:53 +0000
committerRoy Marples <uberlord@gentoo.org>2007-09-03 14:39:53 +0000
commitf5ee4bccc7ba3bfe30e0586ca8656b0d0203b990 (patch)
tree6bebc664d65c65f63cd5cd43dd9ca3720e8505d5
parentChangeLog entry (diff)
downloadgentoo-2-f5ee4bccc7ba3bfe30e0586ca8656b0d0203b990.tar.gz
gentoo-2-f5ee4bccc7ba3bfe30e0586ca8656b0d0203b990.tar.bz2
gentoo-2-f5ee4bccc7ba3bfe30e0586ca8656b0d0203b990.zip
Punt old versions
(Portage version: 2.1.3.7)
-rw-r--r--net-mail/dovecot/dovecot-1.0.2-r1.ebuild205
-rw-r--r--net-mail/dovecot/dovecot-1.0_rc29-r1.ebuild205
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0.2-r16
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_rc29-r16
4 files changed, 0 insertions, 422 deletions
diff --git a/net-mail/dovecot/dovecot-1.0.2-r1.ebuild b/net-mail/dovecot/dovecot-1.0.2-r1.ebuild
deleted file mode 100644
index e997bb2b2b2c..000000000000
--- a/net-mail/dovecot/dovecot-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,205 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0.2-r1.ebuild,v 1.2 2007/08/01 11:01:14 uberlord Exp $
-
-inherit autotools eutils ssl-cert
-
-MY_P="${P/_/.}"
-S="${WORKDIR}/${MY_P}"
-SIEVE="dovecot-sieve-1.0.1"
-SIEVE_S="${WORKDIR}/${SIEVE}"
-
-SRC_URI="http://dovecot.org/releases/1.0/${MY_P}.tar.gz
-sieve? ( http://dovecot.org/releases/sieve/${SIEVE}.tar.gz )"
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-
-IUSE="debug doc ipv6 kerberos ldap mbox mysql pop3d pam postgres sieve ssl suid vpopmail"
-
-# Developer documentation, controlled by the doc USE flag
-DEVDOCS="auth-protocol index multiaccess securecoding"
-
-DEPEND=">=sys-apps/sed-4
- kerberos? ( virtual/krb5 )
- ldap? ( net-nds/openldap )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- postgres? ( dev-db/postgresql )
- mysql? ( virtual/mysql )
- vpopmail? ( net-mail/vpopmail )"
-
-RDEPEND="${DEPEND}
- >=net-mail/mailbase-0.00-r8"
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf=
- use ssl && myconf="${myconf} --with-ssl=openssl" \
- || myconf="${myconf} --without-ssl"
-
- econf --localstatedir=/var --sysconfdir=/etc/dovecot \
- --enable-header-install \
- --with-ioloop=best --with-poll=best \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_with kerberos gssapi) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with pam) \
- $(use_with pop3d) \
- $(use_with postgres pgsql) \
- $(use_with vpopmail) \
- ${myconf} || die "configure failed"
- emake || die "make failed"
-
- if use sieve ; then
- einfo "Building sieve"
- cd "${SIEVE_S}"
- econf --with-dovecot="${S}" || die "configure failed"
- emake || die "make failed"
- fi
-}
-
-src_install () {
- make DESTDIR="${D}" install || die "make install failed"
- use suid && fperms u+s /usr/libexec/dovecot/deliver
-
- rm -f "${D}"/etc/dovecot/dovecot-{ldap,sql}-example.conf
-
- newinitd "${FILESDIR}"/dovecot.init dovecot
-
- # Documentation
- rm -rf "${D}"/usr/share/doc/dovecot
- dodoc AUTHORS NEWS README TODO dovecot-example.conf
- if use doc ; then
- dodoc doc/*.txt
- else
- local x= n=
- for x in doc/*.txt ; do
- n=$(basename "${x}" .txt)
- [[ " ${DEVDOCS} " != *" ${n} "* ]] && dodoc "${x}"
- done
- fi
-
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us....
- local conf="${D}/etc/dovecot/dovecot.conf"
- mv "${D}"/etc/dovecot/dovecot-example.conf "${D}"/etc/dovecot/dovecot.conf
-
- # .maildir is the Gentoo default, but we need to support mbox to
- local mail_location="maildir:~/.maildir"
- if use mbox ; then
- mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
- keepdir /var/dovecot
- sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' "${conf}"
- fi
- sed -i -e \
- "s|#mail_location =|mail_location = ${mail_location}|" "${conf}" || die
-
- # We're using pam files (imap and pop3) provided by mailbase
- if use pam ; then
- sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
- "${conf}" || die
- fi
-
- # Listen on ipv6 and ipv4
- if use ipv6 ; then
- sed -i -e 's/^#listen = \*/listen = \[::\]/g' "${conf}" || die
- fi
-
- # Update ssl cert locations
- if use ssl ; then
- sed -i -e 's,^#ssl_cert_file =.*,ssl_cert_file = /etc/ssl/dovecot/server.pem,' \
- -e 's,^#ssl_key_file =.*,ssl_key_file = /etc/ssl/dovecot/server.key,' \
- "${conf}" || die
-
- # Let's not make a new certificate if we already have one
- if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
- -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
- insinto "${ROOT}"/etc/ssl/dovecot
- docert server
- fowners dovecot:mail /etc/ssl/dovecot/server.{key,pem}
- fi
- fi
-
- # Install SQL configuration
- if use mysql || use postgres ; then
- cp doc/dovecot-sql-example.conf "${D}"/etc/dovecot/dovecot-sql.conf
- fperms 600 /etc/dovecot/dovecot-sql.conf
- sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' "${conf}"
- dodoc doc/dovecot-sql-example.conf
- fi
-
- # Install LDAP configuration
- if use ldap ; then
- cp doc/dovecot-ldap-example.conf "${D}"/etc/dovecot/dovecot-ldap.conf
- fperms 600 /etc/dovecot/dovecot-ldap.conf
- sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' "${conf}"
- dodoc doc/dovecot-ldap-example.conf
- fi
-
- # Install sieve plugin
- if use sieve ; then
- make -C "${SIEVE_S}" DESTDIR="${D}" install || die "make install failed"
- fi
-
- dodir /var/run/dovecot
- fowners root:0 /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
-}
-
-get_config_var() {
- sed -n 's/^[[:space:]]\?base_dir[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
- /etc/dovecot/dovecot.conf
-}
-
-pkg_postinst() {
- # Touch ssl certs so that they are modified outisde of src_install
- # We do this so portage does't unmerge them - silly portage
- if use ssl ; then
- touch "${ROOT}"/etc/ssl/dovecot/server.{key,pem}
- fi
-
- elog "The dovecot configuration has vastly changed since 0.99."
- elog "You are encouraged to start afresh with a new configuration file."
- elog "see http://wiki.dovecot.org/ for configuration examples."
-
- if [[ -e ${ROOT}etc/dovecot.conf ]] ; then
- ewarn
- ewarn "dovecot configuration is now in ${ROOT}etc/dovecot"
- fi
-
- local base_dir="$(get_config_var base_dir)"
- base_dir="${basedir:-/var/run/dovecot}"
- if use ssl \
- && [[ ! -e "${ROOT}/${base_dir}/login/ssl-parameters.dat" ]] ; then
- elog
- elog "Dovecot requires DH SSL Parameters if you use SSL connections"
- elog "These take some time to make, and dovecot will create them before"
- elog "it allows any SSL connections."
- elog "You can create them now before starting dovecot like so"
- elog " emerge --config =${PF}"
- fi
-}
-
-pkg_config() {
- local base_dir="$(get_config_var base_dir)"
- base_dir="${base_dir:-/var/run/dovecot}"
-
- einfo "Regenerating SSL parameters. This will take some time."
- /usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
-}
diff --git a/net-mail/dovecot/dovecot-1.0_rc29-r1.ebuild b/net-mail/dovecot/dovecot-1.0_rc29-r1.ebuild
deleted file mode 100644
index bbcf6e822359..000000000000
--- a/net-mail/dovecot/dovecot-1.0_rc29-r1.ebuild
+++ /dev/null
@@ -1,205 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_rc29-r1.ebuild,v 1.2 2007/08/01 11:01:14 uberlord Exp $
-
-inherit autotools eutils ssl-cert
-
-MY_P="${P/_/.}"
-S="${WORKDIR}/${MY_P}"
-SIEVE="dovecot-sieve-1.0"
-SIEVE_S="${WORKDIR}/${SIEVE}"
-
-SRC_URI="http://dovecot.org/releases/1.0/${MY_P}.tar.gz
-sieve? ( http://dovecot.org/releases/sieve/${SIEVE}.tar.gz )"
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="alpha amd64 ppc sparc x86 ~x86-fbsd"
-
-IUSE="debug doc ipv6 kerberos ldap mbox mysql pop3d pam postgres sieve ssl suid vpopmail"
-
-# Developer documentation, controlled by the doc USE flag
-DEVDOCS="auth-protocol index multiaccess securecoding"
-
-DEPEND=">=sys-apps/sed-4
- kerberos? ( virtual/krb5 )
- ldap? ( net-nds/openldap )
- pam? ( virtual/pam )
- ssl? ( dev-libs/openssl )
- postgres? ( dev-db/postgresql )
- mysql? ( virtual/mysql )
- vpopmail? ( net-mail/vpopmail )"
-
-RDEPEND="${DEPEND}
- >=net-mail/mailbase-0.00-r8"
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf=
- use ssl && myconf="${myconf} --with-ssl=openssl" \
- || myconf="${myconf} --without-ssl"
-
- econf --localstatedir=/var --sysconfdir=/etc/dovecot \
- --enable-header-install \
- --with-ioloop=best --with-poll=best \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_with kerberos gssapi) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with pam) \
- $(use_with pop3d) \
- $(use_with postgres pgsql) \
- $(use_with vpopmail) \
- ${myconf} || die "configure failed"
- emake || die "make failed"
-
- if use sieve ; then
- einfo "Building sieve"
- cd "${SIEVE_S}"
- econf --with-dovecot="${S}" || die "configure failed"
- emake || die "make failed"
- fi
-}
-
-src_install () {
- make DESTDIR="${D}" install || die "make install failed"
- use suid && fperms u+s /usr/libexec/dovecot/deliver
-
- rm -f "${D}"/etc/dovecot/dovecot-{ldap,sql}-example.conf
-
- newinitd "${FILESDIR}"/dovecot.init dovecot
-
- # Documentation
- rm -rf "${D}"/usr/share/doc/dovecot
- dodoc AUTHORS NEWS README TODO dovecot-example.conf
- if use doc ; then
- dodoc doc/*.txt
- else
- local x= n=
- for x in doc/*.txt ; do
- n=$(basename "${x}" .txt)
- [[ " ${DEVDOCS} " != *" ${n} "* ]] && dodoc "${x}"
- done
- fi
-
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us....
- local conf="${D}/etc/dovecot/dovecot.conf"
- mv "${D}"/etc/dovecot/dovecot-example.conf "${D}"/etc/dovecot/dovecot.conf
-
- # .maildir is the Gentoo default, but we need to support mbox to
- local mail_location="maildir:~/.maildir"
- if use mbox ; then
- mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
- keepdir /var/dovecot
- sed -i -e 's|#mail_extra_groups =|mail_extra_groups = mail|' "${conf}"
- fi
- sed -i -e \
- "s|#mail_location =|mail_location = ${mail_location}|" "${conf}" || die
-
- # We're using pam files (imap and pop3) provided by mailbase
- if use pam ; then
- sed -i -e '/passdb pam/, /^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
- "${conf}" || die
- fi
-
- # Listen on ipv6 and ipv4
- if use ipv6 ; then
- sed -i -e 's/^#listen = \*/listen = \[::\]/g' "${conf}" || die
- fi
-
- # Update ssl cert locations
- if use ssl ; then
- sed -i -e 's,^#ssl_cert_file =.*,ssl_cert_file = /etc/ssl/dovecot/server.pem,' \
- -e 's,^#ssl_key_file =.*,ssl_key_file = /etc/ssl/dovecot/server.key,' \
- "${conf}" || die
-
- # Let's not make a new certificate if we already have one
- if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
- -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
- insinto "${ROOT}"/etc/ssl/dovecot
- docert server
- fowners dovecot:mail /etc/ssl/dovecot/server.{key,pem}
- fi
- fi
-
- # Install SQL configuration
- if use mysql || use postgres ; then
- cp doc/dovecot-sql-example.conf "${D}"/etc/dovecot/dovecot-sql.conf
- fperms 600 /etc/dovecot/dovecot-sql.conf
- sed -i -e '/db sql/,/args/ s|=|= /etc/dovecot-sql.conf|' "${conf}"
- dodoc doc/dovecot-sql-example.conf
- fi
-
- # Install LDAP configuration
- if use ldap ; then
- cp doc/dovecot-ldap-example.conf "${D}"/etc/dovecot/dovecot-ldap.conf
- fperms 600 /etc/dovecot/dovecot-ldap.conf
- sed -i -e '/db ldap/,/args/ s|=|= /etc/dovecot-ldap.conf|' "${conf}"
- dodoc doc/dovecot-ldap-example.conf
- fi
-
- # Install sieve plugin
- if use sieve ; then
- make -C "${SIEVE_S}" DESTDIR="${D}" install || die "make install failed"
- fi
-
- dodir /var/run/dovecot
- fowners root:0 /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
-}
-
-get_config_var() {
- sed -n 's/^[[:space:]]\?base_dir[[:space:]]*="*\([^#"]\+\)"*/\1/p' \
- /etc/dovecot/dovecot.conf
-}
-
-pkg_postinst() {
- # Touch ssl certs so that they are modified outisde of src_install
- # We do this so portage does't unmerge them - silly portage
- if use ssl ; then
- touch "${ROOT}"/etc/ssl/dovecot/server.{key,pem}
- fi
-
- elog "The dovecot configuration has vastly changed since 0.99."
- elog "You are encouraged to start afresh with a new configuration file."
- elog "see http://wiki.dovecot.org/ for configuration examples."
-
- if [[ -e ${ROOT}etc/dovecot.conf ]] ; then
- ewarn
- ewarn "dovecot configuration is now in ${ROOT}etc/dovecot"
- fi
-
- local base_dir="$(get_config_var base_dir)"
- base_dir="${basedir:-/var/run/dovecot}"
- if use ssl \
- && [[ ! -e "${ROOT}/${base_dir}/login/ssl-parameters.dat" ]] ; then
- elog
- elog "Dovecot requires DH SSL Parameters if you use SSL connections"
- elog "These take some time to make, and dovecot will create them before"
- elog "it allows any SSL connections."
- elog "You can create them now before starting dovecot like so"
- elog " emerge --config =${PF}"
- fi
-}
-
-pkg_config() {
- local base_dir="$(get_config_var base_dir)"
- base_dir="${base_dir:-/var/run/dovecot}"
-
- einfo "Regenerating SSL parameters. This will take some time."
- /usr/libexec/dovecot/ssl-build-param "${base_dir}/login/ssl-parameters.dat"
-}
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0.2-r1 b/net-mail/dovecot/files/digest-dovecot-1.0.2-r1
deleted file mode 100644
index f7f5c8205b0e..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-1.0.2-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 769f0dd2750e7de521de3396999a09e5 dovecot-1.0.2.tar.gz 1768818
-RMD160 0633225e510d1dd72306ff00003f065de25e09c5 dovecot-1.0.2.tar.gz 1768818
-SHA256 d3335076c104eaa08dd01a02db94443790998870a433da5720a8dc79b83c6a03 dovecot-1.0.2.tar.gz 1768818
-MD5 b070d2177009bb555cd7e25c710047d5 dovecot-sieve-1.0.1.tar.gz 444126
-RMD160 9b4a2a3be52b6dfcd3164d82a7139b8ab1a820f9 dovecot-sieve-1.0.1.tar.gz 444126
-SHA256 59f16c23a73b36ff973a8388b601cc2f6408e0a6ae4f882c4adb830e72f3ac66 dovecot-sieve-1.0.1.tar.gz 444126
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_rc29-r1 b/net-mail/dovecot/files/digest-dovecot-1.0_rc29-r1
deleted file mode 100644
index b6e35ba585b9..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-1.0_rc29-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 4b5ab65d59474c8e783ad6bd496fff22 dovecot-1.0.rc29.tar.gz 1670673
-RMD160 b09da68a67e951bf019ab077bf17ebbfd7e729a2 dovecot-1.0.rc29.tar.gz 1670673
-SHA256 6b8431e8276c07e235d30c195946e9b09d1f3e12f28aea6f755b6d4c72008dd9 dovecot-1.0.rc29.tar.gz 1670673
-MD5 dabe564d2ef262a008622737ad84579f dovecot-sieve-1.0.tar.gz 442943
-RMD160 b56f5a7391607125184755b9bbcbe749e79e26d4 dovecot-sieve-1.0.tar.gz 442943
-SHA256 c1ce887c1c6e09d9d1b4af6825db5c50befb10c1fed742a6666a12ac9492d98a dovecot-sieve-1.0.tar.gz 442943