summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-07 22:54:42 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-07 22:54:42 +0000
commitf7ae4fd952ec002921fffd4a35dc4f34510ffe49 (patch)
treeee06155251932c18a153fe077e7f52ec2fb48745
parentUse elog for fetch error. (diff)
downloadgentoo-2-f7ae4fd952ec002921fffd4a35dc4f34510ffe49.tar.gz
gentoo-2-f7ae4fd952ec002921fffd4a35dc4f34510ffe49.tar.bz2
gentoo-2-f7ae4fd952ec002921fffd4a35dc4f34510ffe49.zip
Add patch to fix compilation with gcc 4.4, fixes bug 273837
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--media-radio/svxlink/ChangeLog8
-rw-r--r--media-radio/svxlink/files/svxlink-080730-gcc44.patch55
-rw-r--r--media-radio/svxlink/svxlink-080730.ebuild5
3 files changed, 64 insertions, 4 deletions
diff --git a/media-radio/svxlink/ChangeLog b/media-radio/svxlink/ChangeLog
index 09dd5de9f646..4b3f14e4c0c1 100644
--- a/media-radio/svxlink/ChangeLog
+++ b/media-radio/svxlink/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-radio/svxlink
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.6 2008/12/15 12:27:51 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.7 2009/07/07 22:54:42 vostorga Exp $
+
+ 07 Jul 2009; <vostorga@gentoo.org> +files/svxlink-080730-gcc44.patch,
+ svxlink-080730.ebuild:
+ Add patch to fix compilation with gcc 4.4
15 Dec 2008; Peter Volkov <pva@gentoo.org>
+files/svxlink-080730--as-needed.patch,
diff --git a/media-radio/svxlink/files/svxlink-080730-gcc44.patch b/media-radio/svxlink/files/svxlink-080730-gcc44.patch
new file mode 100644
index 000000000000..f45dbcb5d68e
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-080730-gcc44.patch
@@ -0,0 +1,55 @@
+diff -NrU5 svxlink-080730.original/async/audio/AsyncAudioDevice.h svxlink-080730/async/audio/AsyncAudioDevice.h
+--- svxlink-080730.original/async/audio/AsyncAudioDevice.h 2009-07-07 22:05:53.000000000 -0600
++++ svxlink-080730/async/audio/AsyncAudioDevice.h 2009-07-07 22:44:51.000000000 -0600
+@@ -35,10 +35,11 @@
+ *
+ * System Includes
+ *
+ ****************************************************************************/
+
++#include <stdint.h>
+ #include <sigc++/sigc++.h>
+
+ #include <string>
+ #include <map>
+ #include <list>
+diff -NrU5 svxlink-080730.original/async/core/AsyncSerialDevice.cpp svxlink-080730/async/core/AsyncSerialDevice.cpp
+--- svxlink-080730.original/async/core/AsyncSerialDevice.cpp 2009-07-07 22:05:53.000000000 -0600
++++ svxlink-080730/async/core/AsyncSerialDevice.cpp 2009-07-07 22:40:25.000000000 -0600
+@@ -33,10 +33,11 @@
+ *
+ * System Includes
+ *
+ ****************************************************************************/
+
++#include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <errno.h>
+
+diff -NrU5 svxlink-080730.original/async/cpp/AsyncCppDnsLookupWorker.cpp svxlink-080730/async/cpp/AsyncCppDnsLookupWorker.cpp
+--- svxlink-080730.original/async/cpp/AsyncCppDnsLookupWorker.cpp 2009-07-07 22:05:53.000000000 -0600
++++ svxlink-080730/async/cpp/AsyncCppDnsLookupWorker.cpp 2009-07-07 22:42:37.000000000 -0600
+@@ -36,10 +36,11 @@
+ *
+ * System Includes
+ *
+ ****************************************************************************/
+
++#include <stdio.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <sys/time.h>
+ #include <errno.h>
+diff -NrU5 svxlink-080730.original/async/demo/AsyncSerial_demo.cpp svxlink-080730/async/demo/AsyncSerial_demo.cpp
+--- svxlink-080730.original/async/demo/AsyncSerial_demo.cpp 2009-07-07 22:05:53.000000000 -0600
++++ svxlink-080730/async/demo/AsyncSerial_demo.cpp 2009-07-07 22:46:44.000000000 -0600
+@@ -1,5 +1,6 @@
++#include <stdio.h>
+ #include <iostream>
+ #include <cstdlib>
+
+ #include <AsyncCppApplication.h>
+ #include <AsyncSerial.h>
diff --git a/media-radio/svxlink/svxlink-080730.ebuild b/media-radio/svxlink/svxlink-080730.ebuild
index f560718a7808..2d1ddef61c38 100644
--- a/media-radio/svxlink/svxlink-080730.ebuild
+++ b/media-radio/svxlink/svxlink-080730.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-080730.ebuild,v 1.2 2008/12/15 12:27:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-080730.ebuild,v 1.3 2009/07/07 22:54:42 vostorga Exp $
EAPI=1
@@ -30,6 +30,7 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-fix-Makefile.diff"
epatch "${FILESDIR}/${P}--as-needed.patch"
epatch "${FILESDIR}/${P}-spandsp-0.0.6_pre2.patch"
+ epatch "${FILESDIR}/${P}-gcc44.patch"
}
src_compile() {