summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-08-21 14:39:35 +0000
committerRichard Yao <ryao@gentoo.org>2013-08-21 14:39:35 +0000
commitfb2d2533ba7f31e8f8ef65633288255e1b4f8e38 (patch)
tree1b5482718078143bd932480f79a4086ecb7ce418
parentdrop old (diff)
downloadgentoo-2-fb2d2533ba7f31e8f8ef65633288255e1b4f8e38.tar.gz
gentoo-2-fb2d2533ba7f31e8f8ef65633288255e1b4f8e38.tar.bz2
gentoo-2-fb2d2533ba7f31e8f8ef65633288255e1b4f8e38.zip
New snapshot from upstream. Raises latest supported kernel version from Linux 3.6 to 3.11.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
-rw-r--r--sys-block/iscsitarget/ChangeLog9
-rw-r--r--sys-block/iscsitarget/iscsitarget-1.4.20.2_p20130821.ebuild93
-rw-r--r--sys-block/iscsitarget/iscsitarget-9999.ebuild6
3 files changed, 104 insertions, 4 deletions
diff --git a/sys-block/iscsitarget/ChangeLog b/sys-block/iscsitarget/ChangeLog
index 64ecbfc7e135..3ee771bb6b85 100644
--- a/sys-block/iscsitarget/ChangeLog
+++ b/sys-block/iscsitarget/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/iscsitarget
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.43 2013/08/21 14:29:48 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/ChangeLog,v 1.44 2013/08/21 14:39:35 ryao Exp $
+
+*iscsitarget-1.4.20.2_p20130821 (21 Aug 2013)
+
+ 21 Aug 2013; Richard Yao <ryao@gentoo.org>
+ +iscsitarget-1.4.20.2_p20130821.ebuild, iscsitarget-9999.ebuild:
+ New snapshot from upstream. Raises latest supported kernel version from Linux
+ 3.6 to 3.11.
21 Aug 2013; Richard Yao <ryao@gentoo.org>
iscsitarget-1.4.20.2_p20130103.ebuild, iscsitarget-9999.ebuild:
diff --git a/sys-block/iscsitarget/iscsitarget-1.4.20.2_p20130821.ebuild b/sys-block/iscsitarget/iscsitarget-1.4.20.2_p20130821.ebuild
new file mode 100644
index 000000000000..39b90f6c04c1
--- /dev/null
+++ b/sys-block/iscsitarget/iscsitarget-1.4.20.2_p20130821.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-1.4.20.2_p20130821.ebuild,v 1.1 2013/08/21 14:39:34 ryao Exp $
+
+EAPI="4"
+
+inherit linux-mod eutils flag-o-matic
+
+if [ ${PV} == "9999" ] ; then
+ inherit subversion
+ ESVN_REPO_URI="http://svn.code.sf.net/p/iscsitarget/code/trunk"
+else
+ SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="Open Source iSCSI target with professional features"
+HOMEPAGE="http://iscsitarget.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+MODULE_NAMES="iscsi_trgt(misc:${S}/kernel)"
+
+pkg_setup() {
+ CONFIG_CHECK="CRYPTO_CRC32C"
+ ERROR_CFG="iscsitarget needs support for CRC32C in your kernel."
+
+ kernel_is ge 2 6 14 || die "Linux 2.6.14 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 11 || die "Linux 3.11 is the latest supported version."; }
+
+ linux-mod_pkg_setup
+}
+src_prepare() {
+ if [ ${PV} != "9999" ]
+ then
+ # Fix build system to apply proper patches
+ epatch "${FILESDIR}/${PN}-1.4.20.2_p20130103-fix-3.2-support.patch"
+
+ # Respect LDFLAGS. Bug #365735
+ epatch "${FILESDIR}/${PN}-1.4.20.2-respect-flags-v2.patch"
+
+ # Avoid use of WRITE_SAME_16 in Linux 2.6.32 and earlier
+ epatch "${FILESDIR}/${PN}-1.4.20.2_p20130103-restore-linux-2.6.32-support.patch"
+ fi
+
+ # Apply kernel-specific patches
+ emake KSRC="${KERNEL_DIR}" patch || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake KSRC="${KERNEL_DIR}" usr || die
+
+ unset ARCH
+ emake KSRC="${KERNEL_DIR}" kernel || die
+}
+
+src_install() {
+ einfo "Installing userspace"
+
+ # Install ietd into libexec; we don't need ietd to be in the path
+ # for ROOT, since it's just a service.
+ exeinto /usr/libexec
+ doexe usr/ietd || die
+
+ dosbin usr/ietadm || die
+
+ insinto /etc
+ doins etc/ietd.conf etc/initiators.allow || die
+
+ # We moved ietd in /usr/libexec, so update the init script accordingly.
+ sed -e 's:/usr/sbin/ietd:/usr/libexec/ietd:' "${FILESDIR}"/ietd-init.d-2 > "${T}"/ietd-init.d
+ newinitd "${T}"/ietd-init.d ietd || die
+ newconfd "${FILESDIR}"/ietd-conf.d ietd || die
+
+ # Lock down perms, per bug 198209
+ fperms 0640 /etc/ietd.conf /etc/initiators.allow
+
+ doman doc/manpages/*.[1-9] || die
+ dodoc ChangeLog README RELEASE_NOTES README.initiators README.mcs README.vmware || die
+
+ einfo "Installing kernel module"
+ unset ARCH
+ linux-mod_src_install || die
+}
diff --git a/sys-block/iscsitarget/iscsitarget-9999.ebuild b/sys-block/iscsitarget/iscsitarget-9999.ebuild
index b91420378070..251046e592e0 100644
--- a/sys-block/iscsitarget/iscsitarget-9999.ebuild
+++ b/sys-block/iscsitarget/iscsitarget-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-9999.ebuild,v 1.2 2013/08/21 14:29:48 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/iscsitarget-9999.ebuild,v 1.3 2013/08/21 14:39:34 ryao Exp $
EAPI="4"
@@ -10,7 +10,7 @@ if [ ${PV} == "9999" ] ; then
inherit subversion
ESVN_REPO_URI="http://svn.code.sf.net/p/iscsitarget/code/trunk"
else
- SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.gz"
+ SRC_URI="http://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
KEYWORDS="~amd64 ~ppc ~x86"
fi
@@ -33,7 +33,7 @@ pkg_setup() {
kernel_is ge 2 6 14 || die "Linux 2.6.14 or newer required"
[ ${PV} != "9999" ] && \
- { kernel_is le 3 6 || die "Linux 3.6 is the latest supported version."; }
+ { kernel_is le 3 11 || die "Linux 3.11 is the latest supported version."; }
linux-mod_pkg_setup
}