summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-06 08:13:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-06 08:13:03 +0000
commitfc4c3cd2c53b770a64705ec9aae83934a4a12db3 (patch)
treee598e0aa0a579964038fc1bfcd2a19babf6b34c4
parentInitial commit (diff)
downloadgentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.tar.gz
gentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.tar.bz2
gentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.zip
Fix build with gcc-4.4 Bug #275911
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--media-libs/atlas-c++/ChangeLog11
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.5.ebuild5
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.5.92.ebuild7
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.0.ebuild6
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild16
-rw-r--r--media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch10
6 files changed, 35 insertions, 20 deletions
diff --git a/media-libs/atlas-c++/ChangeLog b/media-libs/atlas-c++/ChangeLog
index 03faed93177f..2001cd33a10f 100644
--- a/media-libs/atlas-c++/ChangeLog
+++ b/media-libs/atlas-c++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/atlas-c++
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.29 2008/11/20 11:04:24 tove Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/ChangeLog,v 1.30 2009/07/06 08:13:03 tupone Exp $
+
+ 06 Jul 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/atlas-c++-0.6.1-gcc-4.4.patch, atlas-c++-0.4.5.ebuild,
+ atlas-c++-0.5.92.ebuild, atlas-c++-0.6.0.ebuild,
+ atlas-c++-0.6.1-r1.ebuild:
+ Fix build with gcc-4.4 Bug #275911 by Joost Ruis
+ Some QA fixes
20 Nov 2008; Tupone Alfredo <tupone@gentoo.org> files/atlas-c++-0.6.1-as-needed.patch:
Adding all dependency within libraries. Tested with -Wl,-no-undefined
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
index 1ba75d5dbfe1..16541ed7e37a 100644
--- a/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.13 2008/02/29 07:23:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.5.ebuild,v 1.14 2009/07/06 08:13:03 tupone Exp $
MY_PN="Atlas-C++"
MY_P=${MY_PN}-${PV}
@@ -16,6 +16,7 @@ IUSE=""
DEPEND="virtual/libc
=dev-libs/libsigc++-1.0*"
+RDEPEND=${DEPEND}
src_compile() {
diff --git a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
index cc8bf556f5d3..a0f82cd2bcdd 100644
--- a/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.5 2008/02/29 07:23:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.5.92.ebuild,v 1.6 2009/07/06 08:13:03 tupone Exp $
inherit eutils
@@ -13,11 +13,12 @@ SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~sparc ~x86"
IUSE=""
DEPEND="virtual/libc
>=dev-libs/libsigc++-1.2"
+RDEPEND=${DEPEND}
src_install() {
make DESTDIR="${D}" install || die
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
index 1b52fd590a4b..e9f837da8fa9 100644
--- a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild,v 1.5 2007/07/21 23:24:35 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild,v 1.6 2009/07/06 08:13:03 tupone Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="bzip2 doc zlib"
RDEPEND=""
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
index 2bf8140638e5..3c6930fe27c0 100644
--- a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.1 2008/11/19 14:47:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.2 2009/07/06 08:13:03 tupone Exp $
+EAPI=2
inherit eutils autotools
@@ -13,7 +14,7 @@ SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="bzip2 doc zlib"
+IUSE="doc"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -21,20 +22,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-strict-aliasing.patch \
"${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch \
"${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}
src_compile() {
- econf \
- $(use_enable zlib) \
- $(use_enable bzip2 bzlib) \
- || die "Error: econf failed!"
emake || die "Error: emake failed!"
if use doc; then
emake docs || die "Error: emake failed!"
diff --git a/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch
new file mode 100644
index 000000000000..ed792935349a
--- /dev/null
+++ b/media-libs/atlas-c++/files/atlas-c++-0.6.1-gcc-4.4.patch
@@ -0,0 +1,10 @@
+--- Atlas/Filter.cpp.old 2009-07-06 09:58:04.000000000 +0200
++++ Atlas/Filter.cpp 2009-07-06 09:58:44.000000000 +0200
+@@ -5,6 +5,7 @@
+ #include <Atlas/Filter.h>
+
+ #include <string.h>
++#include <cstdio>
+
+ namespace Atlas {
+