summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-16 14:19:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-16 14:19:16 +0000
commitfc6544e3029017a3385d502bab6ebd2d608ef3f3 (patch)
tree4d561a7efee7586c6f10343381869eb551ae9518
parentStable on ppc wrt bug 231733 (diff)
downloadgentoo-2-fc6544e3029017a3385d502bab6ebd2d608ef3f3.tar.gz
gentoo-2-fc6544e3029017a3385d502bab6ebd2d608ef3f3.tar.bz2
gentoo-2-fc6544e3029017a3385d502bab6ebd2d608ef3f3.zip
fix exec stacks with mmx asm, still bug #93279
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
-rw-r--r--media-sound/lame/ChangeLog6
-rw-r--r--media-sound/lame/files/lame-3.98-execstacks.patch13
-rw-r--r--media-sound/lame/lame-3.98.ebuild5
3 files changed, 22 insertions, 2 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index d1853eaed6ba..3325c9514d23 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.96 2008/07/16 13:09:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.97 2008/07/16 14:19:15 aballier Exp $
+
+ 16 Jul 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/lame-3.98-execstacks.patch, lame-3.98.ebuild:
+ fix exec stacks with mmx asm, still bug #93279
16 Jul 2008; Alexis Ballier <aballier@gentoo.org>
+files/lame-3.98-pic-fix.patch, lame-3.98.ebuild:
diff --git a/media-sound/lame/files/lame-3.98-execstacks.patch b/media-sound/lame/files/lame-3.98-execstacks.patch
new file mode 100644
index 000000000000..d2c7d4de47fd
--- /dev/null
+++ b/media-sound/lame/files/lame-3.98-execstacks.patch
@@ -0,0 +1,13 @@
+Index: lame-398/libmp3lame/i386/nasm.h
+===================================================================
+--- lame-398.orig/libmp3lame/i386/nasm.h
++++ lame-398/libmp3lame/i386/nasm.h
+@@ -36,7 +36,7 @@ BITS 32
+ %define segment_data segment .data
+ %define segment_bss segment .bss
+ %else
+-%ifdef LINUX
++%ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack progbits noalloc noexec nowrite align=1
+ %endif
+ %define segment_code segment .text align=16 class=CODE use32
diff --git a/media-sound/lame/lame-3.98.ebuild b/media-sound/lame/lame-3.98.ebuild
index 1c3669d7b96a..1c74f4ab0915 100644
--- a/media-sound/lame/lame-3.98.ebuild
+++ b/media-sound/lame/lame-3.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.98.ebuild,v 1.3 2008/07/16 13:09:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.98.ebuild,v 1.4 2008/07/16 14:19:15 aballier Exp $
inherit flag-o-matic toolchain-funcs eutils autotools versionator
@@ -44,6 +44,9 @@ src_unpack() {
# PIC Fix by the PaX Team, bug #93279
epatch "${FILESDIR}"/${PN}-3.98-pic-fix.patch
+ # Let it use proper %if statements for marking stacks as non executable
+ epatch "${FILESDIR}"/${PN}-3.98-execstacks.patch
+
AT_M4DIR="${S}" eautoreconf
epunt_cxx # embedded bug #74498
}