summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-06-01 14:46:10 +0000
committerDane Smith <c1pher@gentoo.org>2011-06-01 14:46:10 +0000
commitfe56a190af27838b4f7554b2c36a58c386e98000 (patch)
treee56de0d01f77b96347832d39384c70eda84aab90
parentBump to epic5-1.1.2 for bug #258144. Includes patches for a lot of automagic ... (diff)
downloadgentoo-2-fe56a190af27838b4f7554b2c36a58c386e98000.tar.gz
gentoo-2-fe56a190af27838b4f7554b2c36a58c386e98000.tar.bz2
gentoo-2-fe56a190af27838b4f7554b2c36a58c386e98000.zip
app-crypt/truecrypt: Revbump. Add new patch. Fixes bug 369203.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
-rw-r--r--app-crypt/truecrypt/ChangeLog10
-rw-r--r--app-crypt/truecrypt/files/makefile-archdetect.diff11
-rw-r--r--app-crypt/truecrypt/truecrypt-7.0a-r3.ebuild126
3 files changed, 146 insertions, 1 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 27d159b51c2e..a5e2bd96d697 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.61 2011/04/25 14:15:37 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.62 2011/06/01 14:46:10 c1pher Exp $
+
+*truecrypt-7.0a-r3 (01 Jun 2011)
+
+ 01 Jun 2011; Dane Smith <c1pher@gentoo.org> +truecrypt-7.0a-r3.ebuild,
+ +files/makefile-archdetect.diff:
+ Add new patch to fix arch detection for the i{3,5,7} processors.
+ Revbump to r3 and include that patch. Fixes bug 369203.
+ Paxmark the installed binary.
25 Apr 2011; Dane Smith <c1pher@gentoo.org> truecrypt-7.0a-r2.ebuild:
Re-added the fetch and mirror restriction after a conversation on -dev.
diff --git a/app-crypt/truecrypt/files/makefile-archdetect.diff b/app-crypt/truecrypt/files/makefile-archdetect.diff
new file mode 100644
index 000000000000..c01c670bbdaf
--- /dev/null
+++ b/app-crypt/truecrypt/files/makefile-archdetect.diff
@@ -0,0 +1,11 @@
+--- Makefile 2010-09-05 10:32:10.000000000 -0400
++++ Makefile.new 2011-06-01 10:17:41.575000055 -0400
+@@ -128,7 +128,7 @@
+ ifneq (,$(filter i386 i486 i586 i686 x86,$(ARCH)))
+ CPU_ARCH = x86
+ ASM_OBJ_FORMAT = elf32
+-else ifneq (,$(filter x86_64 x86-64 amd64 x64,$(ARCH)))
++else ifneq (,$(filter i3 i5 i7 x86_64 x86-64 amd64 x64,$(ARCH)))
+ CPU_ARCH = x64
+ ASM_OBJ_FORMAT = elf64
+ endif
diff --git a/app-crypt/truecrypt/truecrypt-7.0a-r3.ebuild b/app-crypt/truecrypt/truecrypt-7.0a-r3.ebuild
new file mode 100644
index 000000000000..cbb474998993
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-7.0a-r3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.0a-r3.ebuild,v 1.1 2011/06/01 14:46:10 c1pher Exp $
+
+EAPI="2"
+
+inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets eutils \
+ pax-utils
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="truecrypt-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+RESTRICT="mirror fetch bindist"
+
+RDEPEND="|| ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper )
+ sys-fs/fuse
+ x11-libs/wxGTK:2.8[X?]"
+DEPEND="${RDEPEND}
+ || ( dev-libs/pkcs11-helper dev-libs/opensc )"
+RDEPEND="${RDEPEND}
+ app-admin/sudo"
+
+S="${WORKDIR}/${P}-source"
+
+#See bug 241650.
+pkg_nofetch() {
+ elog "Please download ${P}-linux-{86,64}.tar.gz source from:"
+ elog "http://www.truecrypt.org/downloads2"
+ elog "Then put the file in ${DISTDIR}/${P}.tar.gz"
+}
+
+pkg_setup() {
+ local CONFIG_CHECK="~BLK_DEV_DM ~DM_CRYPT ~FUSE_FS ~CRYPTO ~CRYPTO_XTS"
+ linux-info_pkg_setup
+
+ local WX_GTK_VER="2.8"
+ if use X; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+}
+
+src_prepare() {
+ if has_version x11-libs/wxGTK[X]; then
+ # Fix linking when NOGUI=1
+ sed -e "s/WX_CONFIG_LIBS := base/&,core/" -i Main/Main.make || die "sed Main/Main.make failed"
+ fi
+
+ epatch "${FILESDIR}/makefile-archdetect.diff"
+}
+
+src_compile() {
+ local EXTRA pkcs11_include_directory
+
+ use X || EXTRA+=" NOGUI=1"
+
+ if has_version dev-libs/pkcs11-helper; then
+ pkcs11_include_directory="/usr/include/pkcs11-helper-1.0"
+ else
+ pkcs11_include_directory="/usr/include/opensc"
+ fi
+ append-flags -DCKR_NEW_PIN_MODE=0x000001B0 -DCKR_NEXT_OTP=0x000001B1
+
+ emake \
+ ${EXTRA} \
+ NOSTRIP=1 \
+ NOTEST=1 \
+ VERBOSE=1 \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ TC_EXTRA_CFLAGS="${CFLAGS}" \
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ TC_EXTRA_LFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${WX_CONFIG}" \
+ PKCS11_INC="${pkcs11_include_directory}" \
+ || die "emake failed"
+}
+
+src_test() {
+ "${S}/Main/truecrypt" --text --test || die "tests failed"
+}
+
+src_install() {
+ dobin Main/truecrypt || die
+ dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf" || die
+ exeinto "/$(get_libdir)/rcscripts/addons"
+ newexe "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh" || die
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN} || die
+
+ if use X; then
+ newicon Resources/Icons/TrueCrypt-48x48.xpm truecrypt.xpm || die
+ make_desktop_entry ${PN} "TrueCrypt" ${PN} "System" || die
+ fi
+
+ pax-mark -m "${D}/usr/bin/truecrypt" || die
+}
+
+pkg_postinst() {
+ elog "There is now an init script for TrueCrypt for Baselayout-2."
+ elog "If you are a baselayout-2 user and you would like the TrueCrypt"
+ elog "mappings removed on shutdown in order to prevent other file systems"
+ elog "from unmounting then run:"
+ elog "rc-update add truecrypt boot"
+ elog ""
+
+ ewarn "If you're getting errors about DISPLAY while using the terminal"
+ ewarn "it's a known upstream bug. To use TrueCrypt from the terminal"
+ ewarn "all that's necessary is to run: unset DISPLAY"
+ ewarn "This will make the display unaccessable from that terminal "
+ ewarn "but at least you will be able to access your volumes."
+ ewarn ""
+
+ ewarn "TrueCrypt has very restrictive license."
+ ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
+ ewarn "directory before using TrueCrypt. Please be explicitly aware of"
+ ewarn "the limitations on redistribution of binaries or modified source."
+}