summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-19 22:47:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-19 22:47:00 +0000
commitfebc3976fc3d3253d576032149776083e32559d0 (patch)
tree9a7fdd812e9f76e1d2ea4e71c480f3fb83f3db2d
parentstable x86, bug 210642 (diff)
downloadgentoo-2-febc3976fc3d3253d576032149776083e32559d0.tar.gz
gentoo-2-febc3976fc3d3253d576032149776083e32559d0.tar.bz2
gentoo-2-febc3976fc3d3253d576032149776083e32559d0.zip
Version bump #210727.
(Portage version: 2.2_pre2)
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/findutils-4.3.13.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 86aad2c7f3ea..99928280af74 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.156 2008/02/19 22:37:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.157 2008/02/19 22:47:00 vapier Exp $
+
+*findutils-4.3.13 (19 Feb 2008)
+
+ 19 Feb 2008; Mike Frysinger <vapier@gentoo.org> +findutils-4.3.13.ebuild:
+ Version bump #210727.
*findutils-4.2.33 (19 Feb 2008)
diff --git a/sys-apps/findutils/findutils-4.3.13.ebuild b/sys-apps/findutils/findutils-4.3.13.ebuild
new file mode 100644
index 000000000000..cbaa06bbdfa1
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.3.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.13.ebuild,v 1.1 2008/02/19 22:47:00 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SELINUX_PATCH="findutils-4.3.12-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}