summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-06-19 17:45:19 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-06-19 17:45:19 +0000
commit1caa1aeacd8de443a4a82aba2d63aa6960296f47 (patch)
treed1470367cd52cfbedf697e6336fe1e37237a83ba /app-accessibility/edbrowse
parentDrop MY_P, bump to eapi4, add missing dependency on app-arch/unzip, drop test... (diff)
downloadgentoo-2-1caa1aeacd8de443a4a82aba2d63aa6960296f47.tar.gz
gentoo-2-1caa1aeacd8de443a4a82aba2d63aa6960296f47.tar.bz2
gentoo-2-1caa1aeacd8de443a4a82aba2d63aa6960296f47.zip
added support for spidermonkey-1.8.7, relates to bug 422169
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility/edbrowse')
-rw-r--r--app-accessibility/edbrowse/ChangeLog7
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.4.8.ebuild13
2 files changed, 15 insertions, 5 deletions
diff --git a/app-accessibility/edbrowse/ChangeLog b/app-accessibility/edbrowse/ChangeLog
index dc8186e79362..94e6234cd6fd 100644
--- a/app-accessibility/edbrowse/ChangeLog
+++ b/app-accessibility/edbrowse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/edbrowse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.8 2011/11/15 16:38:16 axs Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.9 2012/06/19 17:45:19 axs Exp $
+
+ 19 Jun 2012; Ian Stakenvicius <axs@gentoo.org> edbrowse-3.4.8.ebuild:
+ added support for spidermonkey-1.8.7, relates to bug 422169
*edbrowse-3.4.8 (15 Nov 2011)
diff --git a/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild b/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild
index cff30ab7b4ff..b28c4a6194df 100644
--- a/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild
+++ b/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild,v 1.1 2011/11/15 16:35:58 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.8.ebuild,v 1.2 2012/06/19 17:45:19 axs Exp $
EAPI="4"
inherit eutils
@@ -19,11 +19,18 @@ COMMON_DEPEND=">=dev-lang/spidermonkey-1.8.5
>=dev-libs/openssl-0.9.8j
odbc? ( dev-db/unixODBC )"
DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
app-arch/unzip"
RDEPEND="${COMMON_DEPEND}"
src_compile() {
- emake -j1 prefix=/usr STRIP=''
+ local jslib="-lmozjs185"
+ local jscppflags="-DXP_UNIX -DX86_LINUX -I/usr/include/js"
+ if has_version ~dev-lang/spidermonkey-1.8.7 ; then
+ jscppflags=$(pkg-config --cflags mozjs187)
+ jslib=$(pkg-config --libs mozjs187)
+ fi
+ emake -j1 prefix=/usr JSLIB="${jslib}" JS_CPPFLAGS="${jscppflags}" STRIP=''
if use odbc; then
# Top-level makefile doesn't have this target.
cd src