summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-11 20:09:35 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-11 20:09:35 +0000
commit5d58963fa2942b093fc3b4b96d9c03dadbd36938 (patch)
treed0c70cd2690ce854bb5354fd16848162f52a2f82 /app-accessibility/flite
parentEnable multilib support. (diff)
downloadgentoo-2-5d58963fa2942b093fc3b4b96d9c03dadbd36938.tar.gz
gentoo-2-5d58963fa2942b093fc3b4b96d9c03dadbd36938.tar.bz2
gentoo-2-5d58963fa2942b093fc3b4b96d9c03dadbd36938.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-accessibility/flite')
-rw-r--r--app-accessibility/flite/ChangeLog7
-rw-r--r--app-accessibility/flite/flite-1.4-r4.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/app-accessibility/flite/ChangeLog b/app-accessibility/flite/ChangeLog
index 67b7668a87dd..2918f093b28a 100644
--- a/app-accessibility/flite/ChangeLog
+++ b/app-accessibility/flite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/flite
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/ChangeLog,v 1.51 2014/05/27 19:22:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/ChangeLog,v 1.52 2014/06/11 20:09:35 mgorny Exp $
+
+*flite-1.4-r4 (11 Jun 2014)
+
+ 11 Jun 2014; Michał Górny <mgorny@gentoo.org> +flite-1.4-r4.ebuild:
+ Enable multilib support.
27 May 2014; Markos Chandras <hwoarang@gentoo.org> flite-1.3-r1.ebuild:
Stable on amd64 wrt bug #510260
diff --git a/app-accessibility/flite/flite-1.4-r4.ebuild b/app-accessibility/flite/flite-1.4-r4.ebuild
new file mode 100644
index 000000000000..3f3b7840bbde
--- /dev/null
+++ b/app-accessibility/flite/flite-1.4-r4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.4-r4.ebuild,v 1.1 2014/06/11 20:09:35 mgorny Exp $
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Flite text to speech engine"
+HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
+SRC_URI=" http://www.speech.cs.cmu.edu/${PN}/packed/${P}/${P}-release.tar.bz2"
+
+LICENSE="BSD freetts public-domain regexp-UofT BSD-2"
+SLOT="0"
+KEYWORDS=" ~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa oss static-libs"
+
+DEPEND="alsa? ( >=media-libs/alsa-lib-1.0.24.1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-release
+
+get_audio() {
+ if use alsa; then
+ echo alsa
+ elif use oss; then
+ echo oss
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tempfile.patch
+ epatch "${FILESDIR}"/${P}-fix-parallel-builds.patch
+ epatch "${FILESDIR}"/${P}-respect-destdir.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-audio-interface.patch
+ sed -i main/Makefile \
+ -e '/-rpath/s|$(LIBDIR)|$(INSTALLLIBDIR)|g' \
+ || die
+ eautoreconf
+
+ # custom makefiles
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! use static-libs; then
+ myconf+=( --enable-shared )
+ fi
+ myconf+=( --with-audio=$(get_audio) )
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+multilib_src_install_all() {
+ dodoc ACKNOWLEDGEMENTS README
+
+ if ! use static-libs; then
+ rm -rf "${D}"/usr/lib*/*.a
+ fi
+}
+
+pkg_postinst() {
+ if [[ "$(get_audio)" = "none" ]]; then
+ ewarn "you have built flite without audio support."
+ ewarn "If you want audio support, re-emerge"
+ ewarn "flite with alsa or oss in your use flags."
+ fi
+}