summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-04-27 18:30:32 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-04-27 18:30:32 +0000
commit215006419a8ffc62c7a385fe1eeb8d2ba432015e (patch)
treea6d4d39344fd9cd1227341029303e0d8d99449a5 /app-accessibility
parentVersion bump. (diff)
downloadgentoo-2-215006419a8ffc62c7a385fe1eeb8d2ba432015e.tar.gz
gentoo-2-215006419a8ffc62c7a385fe1eeb8d2ba432015e.tar.bz2
gentoo-2-215006419a8ffc62c7a385fe1eeb8d2ba432015e.zip
Check for CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT for bug #365105.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeakup/ChangeLog6
-rw-r--r--app-accessibility/espeakup/espeakup-0.71.ebuild22
-rw-r--r--app-accessibility/espeakup/espeakup-9999.ebuild22
3 files changed, 42 insertions, 8 deletions
diff --git a/app-accessibility/espeakup/ChangeLog b/app-accessibility/espeakup/ChangeLog
index 97fa5f8e0e39..488b513b5730 100644
--- a/app-accessibility/espeakup/ChangeLog
+++ b/app-accessibility/espeakup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/espeakup
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.19 2011/01/12 23:56:02 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/ChangeLog,v 1.20 2011/04/27 18:30:32 williamh Exp $
+
+ 27 Apr 2011; William Hubbs <williamh@gentoo.org> espeakup-0.71.ebuild,
+ espeakup-9999.ebuild:
+ Check for CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT for bug #365105.
12 Jan 2011; William Hubbs <williamh@gentoo.org> espeakup-0.71.ebuild,
espeakup-9999.ebuild:
diff --git a/app-accessibility/espeakup/espeakup-0.71.ebuild b/app-accessibility/espeakup/espeakup-0.71.ebuild
index 14f7ea8e58a7..147e67976aad 100644
--- a/app-accessibility/espeakup/espeakup-0.71.ebuild
+++ b/app-accessibility/espeakup/espeakup-0.71.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.71.ebuild,v 1.7 2011/01/12 23:56:02 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.71.ebuild,v 1.8 2011/04/27 18:30:32 williamh Exp $
+
+inherit linux-info
DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
HOMEPAGE="http://www.linux-speakup.org"
@@ -12,8 +14,22 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="app-accessibility/espeak"
-RDEPEND="${DEPEND}
- || ( >=virtual/linux-sources-2.6.37 app-accessibility/speakup )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is -ge 2 6 37; then
+ CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ ERROR_SPEAKUP_SYNTH_SOFT=\
+ "CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+ check_extra_config
+ elif ! has_version app-accessibility/speakup; then
+ ewarn "Cannot find speakup on your system."
+ ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
+ ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
+ ewarn "or install app-accessibility/speakup."
+ fi
+}
src_compile() {
emake || die "Compile failed."
diff --git a/app-accessibility/espeakup/espeakup-9999.ebuild b/app-accessibility/espeakup/espeakup-9999.ebuild
index 717bf6cc33b2..d346a5a97119 100644
--- a/app-accessibility/espeakup/espeakup-9999.ebuild
+++ b/app-accessibility/espeakup/espeakup-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-9999.ebuild,v 1.6 2011/01/12 23:56:02 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-9999.ebuild,v 1.7 2011/04/27 18:30:32 williamh Exp $
EGIT_REPO_URI="git://github.com/williamh/espeakup.git"
-inherit git
+inherit git linux-info
DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
HOMEPAGE="http://www.github.com/williamh/espeakup"
@@ -15,8 +15,22 @@ KEYWORDS=""
IUSE=""
DEPEND="app-accessibility/espeak"
-RDEPEND="${DEPEND}
- || ( >=virtual/linux-sources-2.6.37 app-accessibility/speakup )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is -ge 2 6 37; then
+ CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ ERROR_SPEAKUP_SYNTH_SOFT=\
+ "CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+ check_extra_config
+ elif ! has_version app-accessibility/speakup; then
+ ewarn "Cannot find speakup on your system."
+ ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
+ ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
+ ewarn "or install app-accessibility/speakup."
+ fi
+}
src_compile() {
emake || die "Compile failed."