summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-10-25 18:54:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-10-25 18:54:42 +0000
commit27aec2428268e5495f8c012497a145cf2a6a3d97 (patch)
treef441167b5abacc744c8f4d930a653a064e18f29a /app-accessibility
parentcheck for blockdevice - not file (diff)
downloadgentoo-2-27aec2428268e5495f8c012497a145cf2a6a3d97.tar.gz
gentoo-2-27aec2428268e5495f8c012497a145cf2a6a3d97.tar.bz2
gentoo-2-27aec2428268e5495f8c012497a145cf2a6a3d97.zip
Support USE=modules for kernels with merged speakup. Not compile tested as speakup fails to build against 2.6.32-rc5.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speakup/ChangeLog9
-rw-r--r--app-accessibility/speakup/speakup-3.1.3-r1.ebuild76
2 files changed, 84 insertions, 1 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index e7a5fc049f84..745338a98331 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.36 2009/09/11 03:10:27 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.37 2009/10/25 18:54:42 robbat2 Exp $
+
+*speakup-3.1.3-r1 (25 Oct 2009)
+
+ 25 Oct 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +speakup-3.1.3-r1.ebuild:
+ Support USE=modules for kernels with merged speakup. Not compile tested as
+ speakup fails to build against 2.6.32-rc5.
11 Sep 2009; William Hubbs <williamh@gentoo.org> -speakup-3.1.1.ebuild,
-speakup-3.1.2.ebuild:
diff --git a/app-accessibility/speakup/speakup-3.1.3-r1.ebuild b/app-accessibility/speakup/speakup-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..d63fb7541dd7
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-3.1.3-r1.ebuild,v 1.1 2009/10/25 18:54:42 robbat2 Exp $
+
+EAPI="2"
+
+inherit linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ case ${KV_EXTRA} in
+ *gentoo)
+ if kernel_is lt 2 6 25; then
+ $cmd "Speakup requires at least gentoo-sources-2.6.25"
+ fi
+ ;;
+ *)
+ if kernel_is lt 2 6 26; then
+ $cmd "Speakup requires at least kernel version 2.6.26"
+ fi
+ ;;
+ esac
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dobin tools/speakupconf
+ dosbin tools/talkwith
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ newdoc tools/README README.tools
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}