summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-03-13 20:32:58 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-03-13 20:32:58 +0000
commitd2fae42ccc134acf51da514d4461c228d7443563 (patch)
treed750a0429214be42122438a63fb86cf4969e1667 /app-accessibility
parentInitial commit of viewnior application. Fixes bug #301041 (diff)
downloadgentoo-2-d2fae42ccc134acf51da514d4461c228d7443563.tar.gz
gentoo-2-d2fae42ccc134acf51da514d4461c228d7443563.tar.bz2
gentoo-2-d2fae42ccc134acf51da514d4461c228d7443563.zip
Renamed /usr/bin/dp to /usr/bin/speech-dp wrt bug #287983
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-tools/ChangeLog10
-rw-r--r--app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild104
2 files changed, 112 insertions, 2 deletions
diff --git a/app-accessibility/speech-tools/ChangeLog b/app-accessibility/speech-tools/ChangeLog
index 5bd35045c171..f948dbed66ad 100644
--- a/app-accessibility/speech-tools/ChangeLog
+++ b/app-accessibility/speech-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-tools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.64 2009/07/23 16:49:06 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.65 2010/03/13 20:32:58 neurogeek Exp $
+
+*speech-tools-1.2.96_beta-r1 (13 Mar 2010)
+
+ 13 Mar 2010; Jesus Rivero <neurogeek@gentoo.org>
+ +speech-tools-1.2.96_beta-r1.ebuild:
+ Renamed /usr/bin/dp to /usr/bin/speech-dp wrt bug #287983
23 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
speech-tools-1.2.96_beta.ebuild,
diff --git a/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild b/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild
new file mode 100644
index 000000000000..ce699bbac9ae
--- /dev/null
+++ b/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild,v 1.1 2010/03/13 20:32:58 neurogeek Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/speech-/speech_}
+MY_P=${MY_P/_beta/-beta}
+
+DESCRIPTION="Speech tools for Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/speech_tools/"
+SRC_URI="http://www.festvox.org/packed/festival/latest/${MY_P}.tar.gz"
+LICENSE="FESTIVAL BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="esd nas X"
+
+RDEPEND="esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ X? ( x11-libs/libX11
+ x11-libs/libXt )
+ !<app-accessibility/festival-1.96_beta
+ !sys-power/powerman"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/speech_tools
+
+src_unpack() {
+ local CONFIG=${S}/config/config.in
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-gcc42.patch \
+ "${FILESDIR}"/${P}-gcc43-include.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+
+# set compiler flags for base_class
+ sed -i -e "s:-O3:\$(OPTIMISE_CXXFLAGS):" "${S}"/base_class/Makefile
+
+ # enable building shared libraries
+ sed -i -e "s/#.*\(SHARED=2\)/\1/" ${CONFIG}
+
+ use esd && sed -i -e "s/#.*\(INCLUDE_MODULES += ESD_AUDIO\)/\1/" ${CONFIG}
+ use nas && sed -i -e "s/#.*\(INCLUDE_MODULES += NAS_AUDIO\)/\1/" ${CONFIG}
+ use X || sed -i -e "s/-lX11 -lXt//" "${S}"/config/modules/esd_audio.mak
+}
+
+src_compile() {
+ econf || die
+ emake -j1 OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ dolib.so lib/libest*.so.1*
+ dosym libestbase.so.1.2.96.1 /usr/$(get_libdir)/libestbase.so
+ dosym libestools.so.1.2.96.1 /usr/$(get_libdir)/libestools.so
+ dosym libeststring.so.1.2 /usr/$(get_libdir)/libeststring.so
+ dolib.a lib/{libestbase.a,libestools.a,libeststring.a}
+
+ cd bin
+ for file in *; do
+ [ "${file}" = "Makefile" ] && continue
+ dobin ${file}
+ dstfile="/usr/bin/${file}"
+ dosed "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" ${dstfile}
+ dosed "s:${S}/bin:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+ dosed "s:${S}/main:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+
+ # This just changes LD_LIBRARY_PATH
+ dosed "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile}
+ done
+
+ cd "${S}"
+ exeinto /usr/$(get_libdir)/speech-tools
+ for file in `find main -perm +100 -type f`; do
+ doexe ${file}
+ done
+
+ insinto /usr/share/speech-tools
+ doins -r config
+
+ insinto /usr/share/speech-tools/lib
+ doins -r lib/siod
+
+ insinto /usr/share/doc/${PF}
+ doins -r lib/example_data
+
+ cd include
+ insinto /usr/include/speech-tools
+ doins -r *
+ dosym /usr/include/speech-tools /usr/share/speech-tools/include
+ cd "${S}"
+
+ dodoc "${S}"/README
+ dodoc "${S}"/lib/cstrutt.dtd
+
+ #Rename to avoid file collisions. See bug #287983
+ mv "${D}/usr/bin/dp" "${D}/usr/bin/speech-dp"
+}
+
+pkg_postinst() {
+ elog "The /usr/bin/dp wrapper script has been renamed to /usr/bin/speech-dp"
+ elog "due to file collision with other programs."
+ elog "See bug #287983 for more details"
+}