summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-05-10 03:27:28 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-05-10 03:27:28 +0000
commitfb3b845b2b8be3312cf54d808231f5d42dfe210a (patch)
treef833e92012bdd361ff465c30e23450a9cbd23eb2 /app-accessibility
parentadded Greenhouse licence for games-server/greenhouse (bug #217901) (diff)
downloadgentoo-2-fb3b845b2b8be3312cf54d808231f5d42dfe210a.tar.gz
gentoo-2-fb3b845b2b8be3312cf54d808231f5d42dfe210a.tar.bz2
gentoo-2-fb3b845b2b8be3312cf54d808231f5d42dfe210a.zip
Add patch to fix compilation with gcc-4.3 by Peter Alfredsen <peter DOT alfredsen AT gmail DOT com>; bug #217606
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/epos/ChangeLog9
-rw-r--r--app-accessibility/epos/epos-2.5.37.ebuild5
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc43.patch23
3 files changed, 33 insertions, 4 deletions
diff --git a/app-accessibility/epos/ChangeLog b/app-accessibility/epos/ChangeLog
index 8ac0d1f663d3..c436b2408a85 100644
--- a/app-accessibility/epos/ChangeLog
+++ b/app-accessibility/epos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/epos
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/ChangeLog,v 1.24 2007/12/26 22:19:50 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/ChangeLog,v 1.25 2008/05/10 03:27:27 halcy0n Exp $
+
+ 10 May 2008; Mark Loeser <halcy0n@gentoo.org>
+ +files/epos-2.5.37-gcc43.patch, epos-2.5.37.ebuild:
+ Add patch to fix compilation with gcc-4.3 by Peter Alfredsen <peter DOT
+ alfredsen AT gmail DOT com>; bug #217606
26 Dec 2007; Christian Heim <phreak@gentoo.org> epos-2.5.23-r1.ebuild:
Fix the quotation.
diff --git a/app-accessibility/epos/epos-2.5.37.ebuild b/app-accessibility/epos/epos-2.5.37.ebuild
index b1e1407db989..92e0d8c996a5 100644
--- a/app-accessibility/epos/epos-2.5.37.ebuild
+++ b/app-accessibility/epos/epos-2.5.37.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/epos-2.5.37.ebuild,v 1.4 2007/09/13 13:31:14 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/epos/epos-2.5.37.ebuild,v 1.5 2008/05/10 03:27:27 halcy0n Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -29,6 +29,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-2.5.35-sysportaudio.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
sed -i -e "s/CCC/#CCC/" configure.ac
eautoreconf
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc43.patch b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
new file mode 100644
index 000000000000..4a61b5ffd04b
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
@@ -0,0 +1,23 @@
+--- epos-2.5.37.orig/src/nnet/neural.cc
++++ epos-2.5.37/src/nnet/neural.cc
+@@ -38,7 +38,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <time.h>
+
+ /*
+--- epos-2.5.37.orig/arch/win/service/install.cpp
++++ epos-2.5.37/arch/win/service/install.cpp
+@@ -23,7 +23,7 @@
+ #include <winsvc.h>
+ #include "service.h"
+ #include <stdio.h> //sprintf & fopen
+-#include <iostream.h>
++#include <iostream>
+ #include "Shlwapi.h"
+
+ SC_HANDLE scm;
+